POJ 1129

Channel Allocation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18963 Accepted: 9602

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

题目大意:

用大写字母表示一个广播电台,用数字代表广播电台的无线频谱,相邻两个电台之间如果运用同样的无线频谱就会互相干扰,所以我们不会让两个相邻电台之间使用同样的无线频谱.

现在问你最少使用几种无线频谱使得这些连接的广播电台之间能够正常运作?

数据规模n<=26,普通暴力搜索直接AC。由四色定理可知最多要四种。但是要注意最后的输出格式,channel(s)。

暴力搜索

程序:

#include <vector>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;

int color[27];
int adj[27][27];
int n;

int set_color(int i) {
    int ans = 0;
    for (int k = 1;k <= n;k++) {
        int flag = 0;
        for (int j = 1;j <= adj[i][0];j++) {
            if (color[adj[i][j]] == k) {
                flag = 1;
                break;
            }
        }
        if (flag == 0) {
            return k;
        }
    }
    return ans;
}

int main()
{
    string str;
    while (scanf("%d", &n) && n != 0) {
        int res = 1;
        memset(color, 0, sizeof(color));
        memset(adj, 0, sizeof(adj));
        for (int i = 0;i < n;i++) {
            cin >> str;
            int len = str.length();
            int from = str[0] - 'A' + 1;
            if (len > 2) {
                adj[from][0] = len-2;
                for (int j = 2;j < len;j++) {
                    int tem = str[j] - 'A' + 1;
                    adj[from][j-1] = tem;
                }
            }
        }
        if (n == 1) {
            printf("1 channel needed.\n");
            continue;
        }
        else {
            for (int i = 1;i <= n;i++) {
                int c = set_color(i);
                color[i] = c;
            }
            for (int i = 1;i <= n;i++) {
                res = res > color[i] ? res : color[i]; 
            }
            if (res == 1) printf("1 channel needed.\n");
            else printf("%d channels needed.\n", res);
        }
    } 
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值