Poj 3321(DFS序,线段树)

problem

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2


思路

题意:

给一棵n个节点的树,每个节点开始有一个苹果,m次操作
1.将某个结点的苹果数异或 1
2.查询一棵子树内的苹果数

求解:
求出树的dfs序,即先序遍历,则一个子树的所有结点对应dfs序上连续的一段
用线段树/树状数组实现单点修改和区间求和


为了进一步理解这种树型转线性对应区间,将样例中结点对应的区间打印:

关系
1 2
1 3
对应区间:
前序   后序
1       3
3       3
2       2




关系
1 5
5 2
5 4
1 3
对应区间:(和输入顺序有关)
前序   后序
1       5
5       5
2       2
4       4
3       5


核心代码(求解DFS序,这里采用的链式向前星存储的边表)

void dfs(int rt,int f){//求dfs序
    Beg[rt]=++Clock;
    for(int i=Head[rt];i!=-1;i=edges[i].to){
        int tt=edges[i].next;//tt是下一个边
        if(tt!=f) dfs(tt,rt);//tt不是父亲
    }
    End[rt]=Clock;
}


代码示例(采用链式向前星存储边表)

#include<iostream>
#include<cstdio>
#include<string.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;

typedef long long LL;

const int maxn=1e5+10;

int sum[maxn<<2];//线段树
int Beg[maxn],End[maxn],Clock;//每个点的DFS序,即为对应区间
int Head[maxn],cnt;//链式前向星

struct Edge{
    int from,to;
}edges[maxn<<1];

void edge_init(){
    cnt=0;
    memset(Head,-1,sizeof(Head));//链式向前套路
}

void edge_add(int u,int v){
    edges[cnt].from=v;
    edges[cnt].to=Head[u];
    Head[u]=cnt++;
}

void dfs(int rt,int f){//求dfs序
    Beg[rt]=++Clock;
    for(int i=Head[rt];i!=-1;i=edges[i].to){
        int tt=edges[i].from;//tt是下一个边
        if(tt!=f) dfs(tt,rt);//tt不是父亲
    }
    End[rt]=Clock;
}

void PushUp(int rt){
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int l,int r,int rt){
    if(l==r){
        sum[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    PushUp(rt);
}

void update(int p,int l,int r,int rt){
    if(l==r){
        sum[rt]^=1;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) update(p,lson);
    else update(p,rson);
    PushUp(rt);
}

int query(int L,int R,int l,int r,int rt){
    if(L<=l&&r<=R){
        return sum[rt];
    }
    int m=(l+r)>>1;
    int ret=0;
    if(L<=m) ret+=query(L,R,lson);
    if(R>m) ret+=query(L,R,rson);
    return ret;
}

int main()
{
    int n,Q;
    while(~scanf("%d",&n))
    {
        Clock=0;
        edge_init();
        for(int i=1;i<n;++i){
            int u,v;
            scanf("%d %d",&u,&v);
            edge_add(u,v);
            edge_add(v,u);
        }
        dfs(1,0);
        build(1,n,1);

        scanf("%d",&Q);
        while(Q--)
        {
            char op[5];
            int x;
            scanf("%s%d",op,&x);
            if(op[0]=='Q') printf("%d\n",query(Beg[x],End[x],1,n,1));
            else update(Beg[x],1,n,1);
        }
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值