HDU-1312 Red and Black

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
题意
有一个人在房间里走动,从@开始,房间里有黑瓷砖'.'和红瓷砖'#',只能在黑瓷砖上走,计算他在这个房间里可以到达的黑色瓷砖的数量,包括他本身所在的黑色瓷砖。题解
简单的深搜,可是我没做出来,看来我今天要做深蹲了,,,,,,,,,,,,,,,,,,,,,,
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[30][30];
int nx[4][2]= {0,1,0,-1,1,0,-1,0},n,m,book[30][30],step;
void dfs(int x,int y)
{
    int tx,ty,i;
    for(i=0; i<4; i++)
    {
        tx=x+nx[i][0];
        ty=y+nx[i][1];
        if(tx<0||ty<0||tx>=n||ty>=m||a[tx][ty]=='#'||book[tx][ty]==1)
            continue;
        if(a[tx][ty]=='.'&&book[tx][ty]==0)
        {
            step++;                                      //瓷砖数量
            book[tx][ty]=1;                             //标记已经加过了,不能在这里写step+1,因为回溯的时候step的值会变
            dfs(tx,ty);
           // book[tx][ty]=0;                           //千万不要加这句,这句在求到达某点的最短路程才用加
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&m,&n)&&(n+m!=0))
    {
        int sum,l,k;
        memset(book,0,sizeof(book));
        for(i=0; i<n; i++)
            scanf("%s",a[i]);
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(a[i][j]=='@')
                {
                    l=i;
                    k=j;
                    break;
                }
            }
        }
        step=1;
        book[l][k] = 1;
        dfs(l,k);
        printf("%d\n",step);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值