DFS-递归与回溯之red and black

题目:

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入:

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

输出:

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

输入样例:

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

输出样例:

45
59
6
13

题意与题解及代码:

就是 ‘ . ’ 为黑砖 ‘ # ’ 为红砖 ,‘ @ ’为起点,从‘ @ ’出发能沿着,‘ . ’走的最大步数。
这个题就是一个典型的dfs遍历图问题,利用dfs深搜,用tot来计数,每调用一次dfs,就tot++一次。从而求出总步数。

#include<bits/stdc++.h>
using namespace std;
int m,n,vis[30][30],tot;//m,n分别表示行和列
//vis用来标记是否走过
//tot记录步数
int xx[4]= {0,0,1,-1},yy[4]= {1,-1,0,0};
char fmap[30][30];//存图
void dfs(int x,int y) {
	tot++;//每来一次就走一次,一开始就算一步
	vis[x][y]=1;//将当前位置标记为走过
	for(int i=0; i<4; i++) {
		int nx=x+xx[i];
		int ny=y+yy[i];
		if(nx>=0&&nx<n&&ny>=0&&ny<m&&vis[nx][ny]!=1&&fmap[nx][ny]=='.')//判断是否走过是否可走
			dfs(nx,ny);
	}
}
int main(){
	while(cin>>m>>n,m!=0,n!=0){
		tot=0;
		memset(vis,0,sizeof(vis));
		for(int i=0;i<n;i++) cin>>fmap[i];//存入行和列 
		for(int i=0;i<n;i++){
			for(int j=0;j<m;j++){
				if(fmap[i][j]=='@'&&!vis[i][j]){ 
				   dfs(i,j);
				   break;
				}
			}
		}
		cout<<tot<<endl;
	}
	return 0;
}

再写一次:

#include <stdio.h>
char a[20][20];
int W,H,cnt=0;//H为行 W为列 cnt为可到达点('.')的数量
int dfs(int x,int y) {
	if(x>=0&&x<H&&y>=0&&y<W&&(a[x][y]=='.'||a[x][y]=='@')) {
		a[x][y]='#';//走过的不再走
		cnt++;
		dfs(x+1,y);
		dfs(x-1,y);
		dfs(x,y+1);
		dfs(x,y-1);
	}
	return 0;
}
int main(void) {
	int i,j,m,n;
	while(~scanf("%d%d",&W,&H)) {
		if(W==0||H==0) continue;//特殊情况
		cnt=0;//初始化操作
		getchar();
		for(i=0; i<H; i++) {
			for(j=0; j<W; j++) {
				scanf("%c",&a[i][j]);
				if(a[i][j]=='@')
					m=i,n=j;//记录起点
			}
			getchar();//清除换行
		}
		dfs(m,n);//从起点开始走
		printf("%d\n",cnt);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值