UVA 10129 Play on Words(并查集)

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve
it to open that doors. Because there is no other way to open the doors, the puzzle is very important
for us.
There is a large number of magnetic plates on every door. Every plate has one word written on
it. The plates must be arranged into a sequence in such a way that every word begins with the same
letter as the previous word ends. For example, the word
acm
' can be followed by the word

m
otorola
‘.
Your task is to write a computer program that will read the list of words and determine whether it
is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to
open the door.
Input
The input consists of
T
test cases. The number of them (
T
) is given on the rst line of the input le.
Each test case begins with a line containing a single integer number
N
that indicates the number of
plates (1

N

100000). Then exactly
N
lines follow, each containing a single word. Each word
contains at least two and at most 1000 lowercase characters, that means only letters
a
' through

z
’ will
appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that
the rst letter of each word is equal to the last letter of the previous word. All the plates from the
list must be used, each exactly once. The words mentioned several times must be used that number of
times.
If there exists such an ordering of plates, your program should print the sentence
Ordering is
possible.
'. Otherwise, output the sentence

The door cannot be opened.

Sample Input
3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok
Sample Output
The door cannot be opened.
Ordering is possible.
The door cannot be opened.

解析:我们可以将每个单词看成首位字母之间的一条边,所以问题就变成了将所有的单词组成欧拉通路,欧拉通路的条件是好判断的(最多有两个出度入度相差1的顶点),我们还需要判断的是图中是否只有一个通路。这里我们引入一个变量cc,表示连通分支数。

#include <bits/stdc++.h>
#define ll long long
#define pb push_back
#define inf 0x3f3f3f3f
#define rep(i,a,b) for(int i=a;i<b;i++)
#define rep1(i,a,b) for(int i=a;i>=b;i--)
using namespace std;
const int N=1e5+100;
string str[N];
int used[256];
int deg[256];
int pre[256];
int fi(int x)
{
    if(x==pre[x])
        return x;
    return fi(pre[x]);
}
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        memset(used,0,sizeof used);
        memset(deg,0,sizeof deg);
        rep(ch,'a','z'+1)
            pre[ch]=ch ;
        cin>>n;
        int cc=26;//表示连通分支数
        rep(i,0,n)
        {
            string str;
            cin>>str;
            char a=str[0],b=str[str.size()-1];
            deg[a]++;
            deg[b]--;
            used[a]=used[b]=1;
            int aa=fi(a),bb=fi(b);
            if(aa!=bb)
            {
                pre[bb]=aa;
                cc--;/*比如说我们输入的是acm malforc,fousk, 
            这里26是减了3,cc变成了23,但是出现的单词数有a,m,c,f,k 
            然后下面减去未出现的要减去21个,最后cc剩下2如果cc剩下的不是1,那就不可能构成 
            欧拉路径了,这里如果是acm,malform,mouse,只需要减去两个,因为有一个地方首尾都是m 
            它们的pa[m]相同,所以这个例子在这里只用减去2*/  
            }
        }
        vector<int>d;
        rep(ch,'a','z'+1)
        {
            if(!used[ch])
                cc--;
            else if(deg[ch]!=0)
                d.pb(deg[ch]);
        }
        int pp=0;
        if(cc==1&&(d.size()==0||d.size()==2&&(d[0]==1||d[0]==-1)))
           pp=1;
        if(!pp)
            cout<<"The door cannot be opened.\n";
        else
            cout<<"Ordering is possible.\n";
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值