hdoj 1116 Play on Words 【并查集+欧拉】

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7258    Accepted Submission(s): 2483


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
题意:一个单词的尾字母和下一个单词的首字母一样就可以连起来,最后能连成一个链,就行。
题解:把一个单词的首字母和为字母分别看作点,并查集合并 + 有向图欧拉通路
#include <cstdio>
#include <cstring>

#define MAX 30
int per[MAX];
int vis[MAX],in[MAX],out[MAX];//访问,入度,出度
int find(int p)//并查集
{
    int r=p;
    int t;
    while(per[p]!=p)
    {
        p=per[p];
    }
    while(r!=p)
    {
        t=per[r];
        per[r]=p;
        r=t;
    }
    return p;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
        per[fx]=fy;
}
int main()
{
    int t,n;
    char str[1001];
    int len,i,st,en;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));//数组 清零
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        for(i=1;i<30;i++)
            per[i]=i;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",str);
            len=strlen(str);
            st=str[0]-'a'+1;
            en=str[len-1]-'a'+1;
            vis[st]=1;
            vis[en]=1;
            in[st]++;
            out[en]++;
            merge(st,en);
        }
        int ans=0;
        for(i=1;i<=26;i++)
        {
            if(vis[i]&&per[i]==i)
                ans++;
        }
        if(ans>1)//根节点不唯一,即不是一颗树
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int x=0,y=0,z=0;//有向图入度大于出度1;入度小于出度1;入度出度相差>1
        for(i=1;i<=26;i++)
        {
            if(vis[i]&&in[i]!=out[i])
            {
                if(in[i]-out[i]==1)
                    x++;
                else if(in[i]-out[i]==-1)
                    y++;
                else
                    z++;
            }
        }
        if(!z&&(x==0&&y==0||x==1&&y==1))//只有2个点入度出度不一样且相差1 ,或是回路
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
        return 0;
}


 大神说 还能用哈密尔顿通路(通过所有点的通路)接着补
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值