UVA 1583 生成元
一、问题描述
原题链接
如果x加上x的各个数字之和得到y,就说x是y的生成元。给出n(1≤n≤100000),求最小生成元。无解输出0。例如,n=216,121,2005时的解分别为198,0,1979。
二、输入格式
三、输出格式
四、样例输入
3
216
121
2005
五、样例输出
198
0
1979
六、思路
法一:(如代码所示)
n-9*n的位数 <= n的生成元 < n
通过界定生成元的范围,减少穷举的时间复杂度
法二:
定义一个长度为100000的int数组a,对于1-100000的每个数i, a[i] = i + i各个位置的数。
再综合法一,即可一劳永逸。(输入样例越多,此法越省时)
七、代码
import java.util.*;
import java.io.*;
public class Main{
static PrintWriter pw;
public static void main(String[] args) throws IOException{
pw = new PrintWriter(System.out);
Reader read = new Reader();
int num = read.nextInt();
for(int i=0; i<num; i++) {
int n = read.nextInt();
int numBit = nB(n);
for(int j=n-9*numBit; j<=n-1; j++) {
if(f(j)==n) {
pw.println(j);
break;
}
if(j==n-1) {
pw.println(0);
}
}
}
pw.close();
}
public static int f(int n) {
int res = n;
while(n>0) {
res += n%10;
n /= 10;
}
return res;
}
private static int nB(int n) {
// TODO Auto-generated method stub
int res = 0;
while(n>0) {
res++;
n /= 10;
}
return res;
}
}
class Reader{
static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
static StringTokenizer tokenizer = new StringTokenizer("");
static String next() throws IOException{
while(!tokenizer.hasMoreTokens()) {
String s = reader.readLine();
if(s==null) {
return null;
}
tokenizer = new StringTokenizer(s);
}
return tokenizer.nextToken();
}
static int nextInt() throws IOException{
return Integer.parseInt(next());
}
static char read() throws IOException{
return (char)reader.read();
}
}
八、总结
- 善用穷举,方便生活
- 打表法的精髓在与于,面对多次测试时,一次打表,永久受益(当然,要注意打表的时间不能太长)