POJ 1068 Parencodings ---YY题

Language:
Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15029 Accepted: 8959

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source



给你一组数

每个数字表示每个右括号之前有几个左括号

要你找出每个 右括号匹配的左括号 从这个右括号向左数开始是第几个左括号...(真拗口...)

其实看看样例就明白了...

思路就是还原括号...构建一个数组储存括号

再遍历一遍找到匹配的括号

#include <set>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <cctype>
#include <cstdio>
#include <string>
#include <vector>
#include <cassert>
#include <cstdlib>
#include <cstring>
#include <sstream>
#include <iostream>
#include <algorithm>
using namespace std;
int seq[500],a[30],b[500],x,n,i,j,k,cnt;                                                         
int main()
{
//	freopen("in.txt","r",stdin);
	cin>>x;
	while(x--)
	{
		memset(b,0,sizeof(b));
		cin>>n;
		for(i=1,j=0;i<=n;i++)
		{
			cin>>a[i];
			for(k=0;k<a[i]-a[i-1];k++,j++)
				seq[j]=0;
			seq[j++]=1;
		}
		for(i=0;i<j;i++)
		{
			if(seq[i]==1)
			{
				for(k=i-1,cnt=1;k>=0;k--)
				{
					if(seq[k]==0 && b[k]==1)
						cnt++;
					else if(seq[k]==0 && b[k]==0)
					{
						b[k]=1;
						cout<<cnt<<" ";
						break;
					}
				}
			}
		}
		cout<<endl;
	}
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值