poj 1068 Parencodings(模拟题)

题目链接:http://poj.org/problem?id=1068


Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 25772 Accepted: 15159

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


All Rights Reserved 2003-2013 Ying Fuchen,Xu Pengcheng,Xie Di
Any problem, Please Contact A


题意:给出每个右括号前面有几个左括号,求每个右括号包含几个括号

解析:将左括号记为1,右括号记为2,存到一个数组里面,遍历数组时每遇到右括号i,然后往前找第一个没标记的左括号j,这个范围内包含了(i - j + 1) / 2

代码:


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>
#include<map>
#include<vector>
#include<stack>
#define N 29
using namespace std;
const int INF = 0x3f3f3f3f;
int a[N], b[N<<1], used[N<<1];

int main()
{
    int t, n;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);
        int cnt = 0, cur = 0;
        memset(used, 0, sizeof(used));
        for(int i = 1; i <= n; i++)
        {
            while((cur++) < a[i]) b[cnt++] = 1;
            b[cnt++] = 2;
            cur = a[i];
        }
        int f = 0;
        for(int i = 0; i < cnt; i++)
        {
            if(!used[i] && b[i] == 2)
            {
                for(int j = i - 1; j >= 0; j--)
                {
                    if(!used[j] && b[j] == 1)
                    {
                        used[j] = 1;
                        a[f++] = (i - j + 1) / 2;
                        break;
                    }
                }
            }
        }
        for(int i = 0; i < n; i++)
           printf("%d%c", a[i], i == n - 1 ? '\n' : ' ');
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值