06:N Queens

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Determine the columns of N queens should be place on. Columns should be greater than 1 and less than N. Columns should be all different. Each column plus its index should be different from others. Each column minus its index should also be different from others.

输入

One positive integer number N (N <= 200).

输出

An N*N 0/1 matrix A = {a[i][j]}, a[i][j]=1 indicates that there is a queue on cell (i,j), and a[i][j]=0 otherwise.

样例输入

4

样例输出

0 1 0 0
0 0 0 1
1 0 0 0
0 0 1 0

#include<bits/stdc++.h>//Writed by Wangzhimin Date: 2022.06.02 
using namespace std;
int a[205],num,t=1;
int b[2000][205];
void queen(int n)
{
    int i;
    if(n==num)
    {
        for(i=0;i<num;++i)
        b[t][i]=a[i];
        t++;
        return ;
    }
    for(i=0;i<num;++i){
        int j;
        for(j=0;j<n;++j){
            if(a[j]==i||abs(a[j]-i)==abs(n-j))
            break;
                    }
      if(j==n){
          a[n]=i;
          queen(n+1);
      }
    }
}
int main()
{
    scanf("%d",&num); 
    queen(0);
    int i;
      //输出,第一个即可 
        for(i=0;i<num;++i){
        for(int j=0;j<num;j++){
            if(j==b[1][i])//列与b中的行同时,输出1,能放的位置。 
            printf("1 ");
            else
            printf("0 ");
            }
       printf("\n");   }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值