31:Candies

总时间限制: 

1000ms

内存限制: 

65536kB

描述

There are N bags. Each bag has some candies. You can take some of the bags. the total number of candies in these bags should be a multiple of K because you want to divide the candies equally between K friends. How many candies can you take at most?

输入

First line: two positive integers N (N <= 100) and K (K <= 1000).
Second line: N positive integers (<= 1000).

输出

One integer.

样例输入

5 3
4 1 5 3 1

样例输出

12

#include<bits/stdc++.h>//Writed by Wangzhimin Date: 2022.06.02 
using namespace std;
int num,k,a[205];
int main()
{
    scanf("%d%d",&num,&k);
    int tot=0; 
    for(int i=0;i<num;i++)
    {
    scanf("%d",&a[i]);
    tot+=a[i];}//求出总数 
    sort(a,a+num);//排序 
    for(int i=0;i<num;i++)
    {
        if(tot%k==0)//能分着吗 
        {
            cout<<tot<<endl;
            break;
        }
        else
        tot-=a[i];//不能减去最小的 
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值