最短路径__Candies ( Poj )

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.

题意:班上有n个同学,现在有一些糖要分给他们,设第i个同学得到的糖为p[i],分糖必须满足条件:第i个同学要求第j个同学的糖不能超过自己k个,即p[j] - p[i] <= k,k >= 0。要求在满足这些条件的情况下,求出p[n] - p[1]的最大值。


思路: 不能超过k个,就保证k个然后转化为 i 到 j 的一个带权边.然后求小路径( 因为要满足其他路径的限制 )


#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
#include<stack>
#include<string.h>
#include<iostream>
#include<stdlib.h>
#define N 30100
#define M 158000
#define INF 0x7fffffff
using namespace std;
struct edge
{
    int u,next;
    int s;

}Edge1[M];
int visit[N];
int head1[N];
int dis[N];
int n,m,Len;

void Insert(int u,int v,int w,edge* Edge,int* head)
{
    Edge[Len].u = v;
    Edge[Len].s = w;
    Edge[Len].next = head[u];
    head[u] = Len;
}

void SPFA(edge* Edge,int* head,int x)
{
    for(int i = 1; i <= n; i ++)visit[i] = false;
    for(int i = 1; i <= n; i ++)dis[i] = INF;
    dis[x] = 0;
    stack<int>team;
    team.push(x);
    visit[1] = 1;
    while(!team.empty())
    {
        int now = team.top();
        team.pop();
        visit[now] = false;
        for(int i = head[now]; i != - 1; i = Edge[i].next)
        {
            int next = Edge[i].u;

            if(dis[next] > dis[now] + Edge[i].s)
            {
                dis[Edge[i].u] = dis[now] + Edge[i].s;
                if(visit[next])continue;
                visit[next] = 1;
                team.push(next);
            }
        }
    }
}

int main()
{
    int t,i,j,k;
    while(scanf("%d%d",&n,&m)!=EOF)
    {

        memset(head1,-1,(n+2)*sizeof(int));
        Len = 0;
        for(i = 0 ; i < m ; i ++)
        {
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            Insert(a,b,c,Edge1,head1);
            Len++;
        }
        SPFA(Edge1,head1,1);
        printf("%d\n",dis[n]);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值