26:The Nearest Number

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Given a sequence of N number and K. Find the nearest number X in the sequence that the absolute value of (X minus K) is minimum.

输入

First line: two positive integers N (N <= 100) and K (K <= 100000).
Second line: N positive integers (<= 100000).

输出

One integer X.

样例输入

4 5
2 4 7 8

样例输出

4

#include<bits/stdc++.h>//Writed by Wangzhimin Date:2022.06.06
using namespace std;
int a[105],num,t=1;
int main()
{
    int m;
    scanf("%d%d",&num,&m);
    for(int i=1;i<=num;i++)
    scanf("%d",&a[i]);
    a[0]=0;//防比第一个数小 
    a[num+1]=100009;//防最大的一个 
    sort(a,a+num+2);//排序 
    for(int i=1;i<=num;i++)
    {
        if(a[i]<=m&&m>a[i+1])//比这个数大,比下个数小 
        {
            if(m-a[i]>a[i+1]-m)
            cout<<a[i+1];
            else
            cout<<a[i];
            break;
        }
    }
    return 0;
}
    


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值