POJ 2236 Wireless Network(并查集)

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. “O p” (1 <= p <= N), which means repairing computer p.
2. “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意描述:
第一行给出两个数字m和d,m代表的是有m台电脑,d代表的是电脑之间信息能传递的最大距离,第2行到m+1行给出的是m个电脑的坐标,然后给一个字母O和一个数字p,表示p这个点的电脑已经修好了,然后会给出一个字母S,和两个数字p和q,问p和q能通信成功吗?

#include<stdio.h>
#include<string.h>
#include<math.h>

int f[1100],n,d;

struct node
{
	int x,y;
	int s; 
}p[1100];

void inti ()
{
	for(int i=1;i<=n;i++)
		f[i]=i;
	return ;
}

int getf(int i)
{
	if(i==f[i])
		return i;
	
	f[i]=getf(f[i]);
	return f[i];
}

void merge(int n,int j)
{
	int t1,t2;
	t1=getf(j);
	for(int i=1;i<=n;i++)
	{
		t2=getf(i);
		if((p[i].s==0)&&((double)sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)*1.0+(p[i].y-p[j].y)*(p[i].y-p[j].y)*1.0)<=d))//判断这个点的电脑是否修好和到这个点的距离是不是小于等于d
			f[t2]=t1;	
	}
	return ;
}

int main(void)
{
	int a,b,c;
	char ch;
	while(scanf("%d%d",&n,&d)!=EOF)
	{
		inti();
		for(int i=1;i<=n;i++)
		{
			scanf("%d%d",&p[i].x,&p[i].y);
			p[i].s=1;//标记此处电脑表示没有修好
		}
		while(~scanf(" %c",&ch))
		{
			
			if(ch=='O')
			{
				scanf("%d",&a);
				p[a].s=0;//释放标记,表示p这个点电脑修好了
				merge(n,a);
			} 
			 if(ch=='S')
			{
				scanf("%d%d",&c,&b);
				
				int t1=getf(c);
				int t2=getf(b); 
				
				if(t1!=t2)
					printf("FAIL\n");
				else
					printf("SUCCESS\n");
			}
		}	
	}	 
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值