浙江省赛problem 1009

115 篇文章 0 订阅
Image Transformation
Time Limit : 2000/1000ms (Java/Other)   Memory Limit :  65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 6
Problem Description
The image stored on a computer can be represented as a matrix of pixels. In the  RGB (Red-Green-Blue) color system, a pixel can be described as a triplex integer  numbers. That is, the color of a pixel is in the format "r g b" where r, g and b  are integers ranging from 0 to 255(inclusive) which represent the Red, Green and  Blue level of that pixel. 

Sometimes however, we may need a gray picture instead of a colorful one. One  of the simplest way to transform a RGB picture into gray: for each pixel, we set  the Red, Green and Blue level to a same value which is usually the average of  the Red, Green and Blue level of that pixel (that is (r + g + b)/3, here we  assume that the sum of r, g and b is always dividable by 3).

You decide to write a program to test the effectiveness of this method.

Input

The input contains multiple test cases!

Each test case begins with two integer numbers N and M (1 <= N,M <= 100) meaning the height and width of the picture, then  threeN *M matrices follow; respectively represent the Red, Green  and Blue level of each pixel.

A line with N = 0 and M = 0 signals the end of the input, which  should not be proceed.

Output

For each test case, output "Case #:" first. "#" is the number of the case,  which starts from 1. Then output a matrix ofN *M integers which  describe the gray levels of the pixels in the resultant grayed picture. There  should beN lines withM integers separated by a comma.

Sample Input

2 2
1 4
6 9
2 5
7 10
3 6
8 11
2 3
0 1 2
3 4 2
0 1 2
3 4 3
0 1 2
3 4 4
0 0

Sample Output

Case 1:
2,5
7,10
Case 2:
0,1,2
3,4,3

 

Source
Zhejiang Provincial Programming Contest 2007
 
 
模拟水
题目大意:html里的RGB配色,输入点阵规模,及每点的RGB值,求中值按点阵格式输出。
题目分析:读题不难(有html基础的话)输入格式有点坑,你得分析出来它输入点阵规模后先按格式输入了R,然后是G,最后B。
#include<stdio.h>
int main()
{
    int a[102][102],m,n,i,j,k,flag,sum=1;
    while(scanf("%d%d",&m,&n)!=EOF&&m&&n)
    {
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                a[i][j]=0;
            }
        }
        k=3;
        while(k--)
        {
            for(i=0; i<m; i++)
            {
                for(j=0; j<n; j++)
                {
                    scanf("%d",&flag);
                    a[i][j]+=flag;
                }
            }
        }
        printf("Case %d:\n",sum);
        for(i=0; i<m; i++)
        {
            for(j=0; j<n; j++)
            {
                if(j)printf(",");
                printf("%d",a[i][j]/3);
            }
            printf("\n");
        }
        sum++;
    }
    return 0;
}
本题核心算法:求三个数的平均数…………
 
 
 
 
 
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值