ZOJ 2857 Image Transformation

The image stored on a computer can be represented as a matrix of pixels. In the RGB (Red-Green-Blue) color system, a pixel can be described as a triplex integer numbers. That is, the color of a pixel is in the format "r g b" where r, g and b are integers ranging from 0 to 255(inclusive) which represent the Red, Green and Blue level of that pixel.

Sometimes however, we may need a gray picture instead of a colorful one. One of the simplest way to transform a RGB picture into gray: for each pixel, we set the Red, Green and Blue level to a same value which is usually the average of the Red, Green and Blue level of that pixel (that is (r + g + b)/3, here we assume that the sum of r, g and b is always dividable by 3).

You decide to write a program to test the effectiveness of this method.

Input

The input contains multiple test cases!

Each test case begins with two integer numbers N and M (1 <= N, M <= 100) meaning the height and width of the picture, then three N * M matrices follow; respectively represent the Red, Green and Blue level of each pixel.

A line with N = 0 and M = 0 signals the end of the input, which should not be proceed.

Output

For each test case, output "Case #:" first. "#" is the number of the case, which starts from 1. Then output a matrix of N * M integers which describe the gray levels of the pixels in the resultant grayed picture. There should be N lines with M integers separated by a comma.

Sample Input

2 2
1 4
6 9
2 5
7 10
3 6
8 11
2 3
0 1 2
3 4 2
0 1 2
3 4 3
0 1 2
3 4 4
0 0

Sample Output

Case 1:
2,5
7,10
Case 2:
0,1,2

3,4,3

比较简单的一道题,代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
#include<functional>
#include<iterator>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
#ifdef ONLINE_JUDGE  
#else  
    freopen("D:\\in.txt", "r", stdin);
    freopen("D:\\out.txt", "w", stdout);
#endif // ONLINE_JUDEG
    int n(0), m(0);
    vector<int> a, b, c,d;
    int t(0);
    int cnt = 0;
    while (cin >> n >> m)
    {
        if (n == 0 && m == 0)
            return 0;
        cnt++;
        a.clear();
        b.clear();
        c.clear();
        d.clear();
        for (int i = 0; i < n*m; i++)
        {
            cin >> t;
            a.push_back(t);
        }
        for (int i = 0; i < n*m; i++)
        {
            cin >> t;
            b.push_back(t);
        }
        for (int i = 0; i < n*m; i++)
        {
            cin >> t;
            c.push_back(t);
        }
        for (int i = 0; i < n*m; i++)
        {
            t = (a[i] + b[i] + c[i]) / 3;
            d.push_back(t);
        }
        cout << "Case " << cnt << ":" << endl;
        for (int i = 0; i < n*m; i++)
        {
            cout << d[i] << ((i+1)%m == 0 ? "\n" : ",");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值