HDU - 6312 GAME(题解)

Alice and Bob are playing a game.
The game is played on a set of positive integers from 1 to n.
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored.
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses.
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

Input

There might be multiple test cases, no more than 10. You need to read till the end of input.
For each test case, a line containing an integer n. (1≤n≤5001≤n≤500)

Output

A line for each test case, 'Yes' or 'No'.

Sample Input

1

Sample Output

Yes

总结:一开眼,看题。博弈题,但博弈题没怎么做过,所以内心有点惧,一开始找规律,写了几个都是Yes,内心更是恐惧,队友对题目产生疑问,我也没信心在做下去了。所以还是要多刷题,积累类似经验,掌握方法。

分析:因为1是任何数的因数所以2种情况:

1.拿1必胜情况。这时候先手拿一必胜。

2.拿1必败,此时先手拿2此时1也被拿去,转化成先手必胜。

代码就很简单了,如下:

#include<iostream>
#include<cstdio>
using namespace std;

int main()
{
	int n;
	while (scanf("%d", &n)!=EOF)
	{
		cout << "Yes" << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值