PAT真题练习(甲级)1136 A Delayed Palindrome (20 分)
Input Specification:
Each input file contains one test case which gives a positive integer no more than 1000 digits.
Output Specification:
For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:
A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations. instead.
Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.
AC代码
#include<iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
using namespace std;
// 字符串相加函数
string Add(string a) {
string b = a;
// 获得反转字符串
reverse(b.begin(), b.end());
string result;
// 用于存储进位
int flag = 0;
for (auto i = 0; i < a.length();i++) {
int tmp = a[i] - '0' + b[i] - '0' + flag;
flag = 0;
if (tmp >= 10) {
tmp -= 10;
flag = 1;
}
result += tmp + '0';
}
if (flag == 1) result += '1';
reverse(result.begin(), result.end());
// 输出计算过程
cout << a << " + " << b << " = " << result << endl;
return result;
}
// 判断是否为回文数
bool isP(string a) {
int len = a.length();
if (len == 1) return true;
string a1 = a.substr(0, len / 2);
string a2 = a.substr(len - len / 2, len / 2);
reverse(a2.begin(), a2.end());
return a1 == a2;
}
int main() {
string n;
cin >> n;
// 最多进行10次操作
for (auto i = 0; i < 10;i++) {
if (isP(n)) {
cout << n << " is a palindromic number.";
return 0;
}
n = Add(n);
}
cout << "Not found in 10 iterations.";
}