完全二叉树判定方法

完全二叉树判定方法

​ 把完全二叉树以数组的形式存储起来,只要结点是连续存放,就可以说明这棵树是完全二叉树。

​ 也就是说,只要最后一个结点的坐标与结点的总数相同,说明这棵树是完全二叉树。

​ 下面给出一道例题:

甲级PAT:1110 Complete Binary Tree (25分)

1110 Complete Binary Tree (25分)

Given a tree, you are supposed to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤20) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each case, print in one line YES and the index of the last node if the tree is a complete binary tree, or NO and the index of the root if not. There must be exactly one space separating the word and the number.

Sample Input 1:

9
7 8
- -
- -
- -
0 1
2 3
4 5
- -
- -

      
    

Sample Output 1:

YES 8

      
    

Sample Input 2:

8
- -
4 5
0 6
- -
2 3
- 7
- -
- -

      
    

Sample Output 2:

NO 1

思路:

  1. 将结点存起来
  2. 数据中不存在点的序号就是根节点
  3. DFS,找到最后一个结点的下标。
  4. 如果下标与结点个数相同,说明是完全二叉树
  5. 在录入数据时,请用string,别用char。数据有可能是两位数。

代码参考:

#include <iostream>
#include <string>
using namespace std;
const int noNode = -1;
struct node
{
	int left, right;
}stor[100];
bool hashTable[100];
int maxn = -1, head = 0, ans = noNode, number;
void init()
{
	scanf("%d\n", &number);
	for(int i=0;i<number;i++)
	{
		string temp1, temp2;
		cin >> temp1 >> temp2;
		if (temp1 != "-") stor[i].left = stoi(temp1), hashTable[stor[i].left] = true;
		else stor[i].left = noNode;
		if (temp2 != "-") stor[i].right = stoi(temp2), hashTable[stor[i].right] = true;
		else stor[i].right = noNode;
	}
}
void DFS(int root,int index)
{
	if (index > maxn) {
		maxn = index;
		ans = root;
	}
	if (stor[root].left != noNode)	DFS(stor[root].left, index * 2);
	if (stor[root].right != noNode) DFS(stor[root].right, index * 2 + 1);
}
int main()
{
	init();
	while (hashTable[head] == true) head++;
	DFS(head, 1);
	if (maxn == number)	cout << "YES " << ans ;
	else cout << "NO " << head ;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
完全二叉树判定可以通过层次遍历来实现。具体过程如下: 1. 对于树中的每个节点,如果其左子节点为空,但是右子节点不为空,则该树不是完全二叉树。 2. 如果当前节点不是满节点,则其后的所有节点都必须是叶子节点,否则该树也不是完全二叉树。 3. 如果遍历过程中没有发现不符合条件的节点,则该树是完全二叉树。 下面是完全二叉树判定的示例代码,其中使用了队列来实现层次遍历: ```python # 定义二叉树节点类 class TreeNode: def __init__(self, val=0, left=None, right=None): self.val = val self.left = left self.right = right # 判断一棵树是否为完全二叉树 def isCompleteTree(root: TreeNode) -> bool: if not root: return True queue = [root] is_full = True while queue: node = queue.pop(0) # 如果节点的左子节点为空,但是右子节点不为空,则该树不是完全二叉树 if not node.left and node.right: return False # 如果当前节点不是满节点,则其后的所有节点都必须是叶子节点,否则该树也不是完全二叉树 if not node.left or not node.right: is_full = False else: # 如果当前节点是满节点,但是之前出现了不是满节点的节点,则该树不是完全二叉树 if not is_full: return False if node.left: queue.append(node.left) if node.right: queue.append(node.right) return True ``` 该函的时间复杂度为 $O(n)$,其中 $n$ 是树中节点的个

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值