Time travel HDU - 4418


Agent K is one of the greatest agents in a secret organization called Men in Black. Once he needs to finish a mission by traveling through time with the Time machine. The Time machine can take agent K to some point (0 to n-1) on the timeline and when he gets to the end of the time line he will come back (For example, there are 4 time points, agent K will go in this way 0, 1, 2, 3, 2, 1, 0, 1, 2, 3, 2, 1, ...). But when agent K gets into the Time machine he finds it has broken, which make the Time machine can't stop (Damn it!). Fortunately, the time machine may get recovery and stop for a few minutes when agent K arrives at a time point, if the time point he just arrive is his destination, he'll go and finish his mission, or the Time machine will break again. The Time machine has probability Pk% to recover after passing k time points and k can be no more than M. We guarantee the sum of Pk is 100 (Sum(Pk) (1 <= k <= M)==100). Now we know agent K will appear at the point X(D is the direction of the Time machine: 0 represents going from the start of the timeline to the end, on the contrary 1 represents going from the end. If x is the start or the end point of the time line D will be -1. Agent K want to know the expectation of the amount of the time point he need to pass before he arrive at the point Y to finish his mission. 
If finishing his mission is impossible output "Impossible !" (no quotes )instead. 
Input
There is an integer T (T <= 20) indicating the cases you have to solve. The first line of each test case are five integers N, M, Y, X .D (0< N,M <= 100, 0 <=X ,Y < 100 ). The following M non-negative integers represent Pk in percentile. 
Output
For each possible scenario, output a floating number with 2 digits after decimal point 
If finishing his mission is impossible output one line "Impossible !" 
(no quotes )instead. 
Sample Input
2
4 2 0 1 0
50 50
4 1 0 2 1
100
Sample Output
8.14
2.00
 
 
 
 
学习了别人的思想才弄出来:
http://blog.csdn.net/sr_19930829/article/details/38959149 上面讲了很详细
题解:有几处细节要考虑
	1.x=y时,直接出答案
	2.构建矩阵时考虑到E[y]或E[n-y]=0,然后该行的除mat[y][y]或mat[n-y][n-y]的所有系数都记为0,用高斯消元自然解出来为0,不用想其他的。
	3.对于根本走不到的点用和2.相同的做法,因为在其他方程中该元素不占用地位,相当等于0.
 
 
#include"stdio.h"
#include"cstdio"
#include"string.h"
#include"algorithm"
#include"queue"
#include"math.h"
using namespace std;
const int max_n=300;
double mat[max_n][max_n];
double P[max_n];
bool used[max_n];
int n,m,y,x,d;
int bfs()
{
	fill(used,used+max_n-1,false);
	used[x]=true;
	queue <int> q;
	q.push(x);
	while(!q.empty())
	{
		int pos=q.front();
		q.pop();
		for(int i=1;i<=m;i++)
		{
			if(P[i])
			{
				int poss=(pos+i)%n;
				if(!used[poss])
				{
					q.push(poss);
					used[poss]=true;
				}
			}
		}
	}
	if(used[y]||used[(n-y)]) return 1;
	return 0;
}
void creat()
{
	double ans=0;
	for(int i=1;i<=m;i++)
	ans+=P[i]*i;
	for(int i=0;i<n;i++)
	{
		mat[i][i]=1;
		if(!used[i]) continue ;
		if(i==y||i==(n-y)%n)
		{
			mat[i][n]=0;
			continue ;
		}
		for(int j=i+1;j<=i+m;j++)
		mat[i][j%n]-=P[j-i];
		mat[i][n]=ans;
	}
}
void swaprow(int x1,int x2)
{
	for(int i=0;i<=n;i++)
	swap(mat[x1][i],mat[x2][i]);
}
int SelectCol()
{
	for(int j=0;j<n;j++)
	{
		int maxx=j;
		for(int i=j;i<n;i++)
		{
			if(fabs(mat[i][j])>fabs(mat[maxx][j]))
			maxx=i;
		}
		if(j!=maxx)
		swaprow(j,maxx);
		for(int i=j+1;i<n;i++)
		{
			if(!mat[j][j]) return 0;
			double temp=mat[i][j]/mat[j][j];
			for(int k=j;k<=n;k++)
			mat[i][k]-=mat[j][k]*temp;
		}
	}
	return 1;
}
int gauss()
{
	if(!SelectCol()) return 0;
	for(int i=n-1;i>=0;i--)
	{
		if(!mat[i][i]) return 0;
		for(int j=i+1;j<n;j++)
		mat[i][n]-=mat[i][j]*mat[j][n];
		mat[i][n]/=mat[i][i];
	}
	return 1;
}
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			int N;
			memset(P,0,sizeof(P));
			memset(mat,0,sizeof(mat));
			scanf("%d%d%d%d%d",&N,&m,&y,&x,&d);
			n=2*N-2;
			if(d>0) x=(n-x)%n; 
			int p;
			for(int i=1;i<=m;i++)
			{
				scanf("%d",&p);
				P[i]=p/100.0;
			}
			if(x==y)
			{
				printf("0.00\n");
				continue ;
			}
			if(!bfs())
			{
				printf("Impossible !\n");
				continue ;
			}
			creat();
			if(!gauss())
			printf("Impossible !\n");
			else
			printf("%.2lf\n",mat[x][n]);
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值