H - Food HDU - 4292

 You, a part-time dining service worker in your college’s dining hall, are now confused with a new problem: serve as many people as possible. 
  The issue comes up as people in your college are more and more difficult to serve with meal: They eat only some certain kinds of food and drink, and with requirement unsatisfied, go away directly. 
  You have prepared F (1 <= F <= 200) kinds of food and D (1 <= D <= 200) kinds of drink. Each kind of food or drink has certain amount, that is, how many people could this food or drink serve. Besides, You know there’re N (1 <= N <= 200) people and you too can tell people’s personal preference for food and drink. 
  Back to your goal: to serve as many people as possible. So you must decide a plan where some people are served while requirements of the rest of them are unmet. You should notice that, when one’s requirement is unmet, he/she would just go away, refusing any service. 
Input  There are several test cases. 
  For each test case, the first line contains three numbers: N,F,D, denoting the number of people, food, and drink. 
  The second line contains F integers, the ith number of which denotes amount of representative food. 
  The third line contains D integers, the ith number of which denotes amount of representative drink. 
  Following is N line, each consisting of a string of length F. e jth character in the ith one of these lines denotes whether people i would accept food j. “Y” for yes and “N” for no. 
  Following is N line, each consisting of a string of length D. e jth character in the ith one of these lines denotes whether people i would accept drink j. “Y” for yes and “N” for no. 
  Please process until EOF (End Of File). 
Output  For each test case, please print a single line with one integer, the maximum number of people to be satisfied. 
Sample Input
4 3 3
1 1 1
1 1 1
YYN
NYY
YNY
YNY
YNY
YYN
YYN
NNY
Sample Output

3


网络流拆点,被时限卡死了,输入看了别人整个字符串的输入才过。敲打


#include <stdio.h>
#include <cstdio>
#include <algorithm>
#include <string.h>
#include <queue>
#define INF 1000000000
using namespace std;
const int max_n=9*(1e6)+10;
int h[1300];
int num,IN;
int dis[1300];
struct Edge
{
    int u,v;
    int flow;
    int next;
}e[max_n];
void add_edge(int u,int v,int flow)
{
    //e[num].u=u;
    e[num].v=v;
    e[num].flow=flow;
    e[num].next=h[u];
    h[u]=num++;
}
int BFS()
{
    for(int i=0;i<=IN;i++) dis[i]=-1;
    queue <int> q;
    q.push(0);
    dis[0]=0;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=h[u];i!=-1;i=e[i].next)
        {
            int v=e[i].v;
            if((dis[v]<0)&&(e[i].flow>0))
            {
                q.push(v);
                dis[v]=dis[u]+1;
                if(v==IN) return 1;
            }
        }
    }
    //if(dis[IN]>0) return 1;
    return 0;
}
int dfs(int u,int f)
{
    if(u==IN) return f;
    int flow;
    for(int i=h[u];i!=-1;i=e[i].next)
    {
        int v=e[i].v;
        if(e[i].flow&&(dis[v]==dis[u]+1)&&(flow=dfs(v,min(f,e[i].flow)))>0)
        {
            e[i].flow-=flow;
            e[i^1].flow+=flow;
            return flow;
        }
    }
    return 0;
}
int max_flow()
{
    int res=0,ans;
    while(BFS())
    {
        while( ans=dfs(0,INF)) res+=ans;
    }
    return res;
}
int main()
{
    int n,d,f;
    while(~scanf("%d%d%d",&n,&f,&d))
    {
        int num=0;
        int N=2*n+f;
        IN=N+d+1;
        for(int i=0;i<=IN;i++) h[i]=-1;
        for(int i=1;i<=f;i++)
        {
            int flow;
            scanf("%d",&flow);
            add_edge(0,i,flow);
            add_edge(i,0,0);
        }
        for(int i=1;i<=n;i++)
        {
            add_edge(i+f,i+n+f,1);
            add_edge(i+n+f,i+f,0);
        }
        for(int i=1;i<=d;i++)
        {
            int flow;
            scanf("%d",&flow);
            add_edge(N+i,IN,flow);
            add_edge(IN,N+i,0);
        }
        char c[11000];
        for(int i=1;i<=n;i++)
        {
            scanf("%s",c+1);
            for(int j=1;j<=f;j++)
            {
                if(c[j]=='Y')
                {
                    add_edge(j,i+f,INF);
                    add_edge(i+f,j,0);
                }
            }
        }
        for(int i=1;i<=n;i++)
        {
            scanf("%s",c+1);
            for(int j=1;j<=d;j++)
            {
                if(c[j]=='Y')
                {
                    add_edge(i+n+f,j+N,INF);
                    add_edge(j+N,i+n+f,0);
                }
            }
        }
        int ret=max_flow();
        printf("%d\n",ret);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值