网络流 POJ - 3281

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers:  NF, and  D 
Lines 2..  N+1: Each line  i starts with a two integers  Fi and  Di, the number of dishes that cow  i likes and the number of drinks that cow  i likes. The next  Fiintegers denote the dishes that cow  i will eat, and the  Di integers following that denote the drinks that cow  i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is: 
Cow 1: no meal 
Cow 2: Food #2, Drink #2 
Cow 3: Food #1, Drink #1 
Cow 4: Food #3, Drink #3 
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.


拆点,把每个牛拆成一条边。流量为1;


#include <stdio.h>
#include <cstdio>
#include <string.h>
#include <algorithm>
#include <queue>
#define INF 0x3f3f3f3f
using namespace std;
const int max_n=3*(1e5)+10;
//int ma[max_n][max_n];
int h[max_n];
int dis[max_n];
int num;
int OUT,IN;
struct Edge
{
	int u,v;
	int val,next;
}e[max_n];
void adde_dge(int u,int v,int val)
{
	e[num].u=u;
	e[num].v=v;
	e[num].val=val;
	e[num].next=h[u];
	h[u]=num++;
}
int BFS(int u)
{
	memset(dis,-1,sizeof(dis));
	queue <int> q;
	q.push(u);
	dis[u]=0;
	while(!q.empty())
	{
		u=q.front();q.pop();
		for(int i=h[u];i!=-1;i=e[i].next)
		{
			int v=e[i].v;
			if(dis[v]==-1&&e[i].val>0) 
			{
				dis[v]=dis[u]+1;
				q.push(v);
			}
		}
	}
	//	std::cout<<"**********"<<IN<<std::endl;
	if(dis[IN]>=0) return 1;
	return 0;
}
int dfs(int u,int f)
{
	if(u==IN) return f;
	if(f<=0) return 0;
	int a;
	for(int i=h[u];i!=-1;i=e[i].next)
	{
		int v=e[i].v;
		if(dis[v]==dis[u]+1&&e[i].val>0&&(a=dfs(v,min(e[i].val,f))))
		{
			e[i].val-=a;
			e[i^1].val+=a;
			return a;
		}
	}
	return 0;
}
int dinic()
{
	int res=0;
	int ans;
	while(BFS(OUT))
	{
		while((ans=dfs(OUT,INF))) res+=ans;
	}
	return res;
}
int main()
{
	int n,f,d;
	while(scanf("%d%d%d",&n,&f,&d)!=EOF)
	{
		int k=n+1;
		num=0;
		IN=f+2*n+d+1;OUT=0;
		memset(h,-1,sizeof(h));
		for(int i=1;i<=n;i++) 
		{
			int a,b,u,v;
			scanf("%d%d",&a,&b);
			for(int j=0;j<a;j++) scanf("%d",&u),adde_dge(u,i+f,1),adde_dge(i+f,u,0);
			for(int j=0;j<b;j++) scanf("%d",&u),adde_dge(i+f+n,u+f+2*n,1),adde_dge(u+f+2*n,i+f+n,0);
		}
		for(int i=f+1;i<n+f+1;i++) adde_dge(i,i+n,1),adde_dge(i+n,i,0);
		for(int i=0;i<f;i++) adde_dge(OUT,i+1,1),adde_dge(i+1,OUT,0);
		for(int i=2*n+1+f;i<IN;i++) adde_dge(i,IN,1),adde_dge(IN,i,0);
		int ret=dinic();
		printf("%d\n",ret);
	}	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值