POJ-3281(Dining)

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2…N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output
3

思路
很好的一道建模题,建立好模型,很容易发现这是一道最大流的题目。
然后运用EK算法即可解题.

AC代码

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
const int INF=0x7fffffff;
const int maxn=2000+5;
int n,m,d;
int vis[maxn],liu[maxn][maxn],p[maxn];
int EK_BFS(int start,int end)
{
	queue<int>q;//不用全局 ,省去清空队列的麻烦 
	memset(vis,0,sizeof(vis));
	memset(p,-1,sizeof(p));
	q.push(start);
	vis[start]=1;
	while(q.size()){
		int t=q.front();
		q.pop();
		if(t==end)
			return 1;//到达汇点 
		for(int i=0;i<=4*(n+m+d);i++){//寻找增广路径 
			if(liu[t][i]!=0&&!vis[i]){ //存在这样的路径并且没有走过 
				vis[i]=1;
				p[i]=t;//记录增广路径 
				q.push(i);
			}
		}
	}
	return 0;//残留图中不再存在增广路径 
}
int EK_network(int start,int end)
{
	int ans=0;
	while(EK_BFS(start,end)){
		int u=end;//利用前驱寻找路径 
		int temp=INF;
		while(p[u]!=-1){
			temp=min(temp,liu[p[u]][u]);
			u=p[u];
		}
		u=end;
		ans+=temp;
		while(p[u]!=-1){
			liu[p[u]][u]-=temp;//改变正向边的容量 
			liu[u][p[u]]+=temp;//反向边,防止出现堵塞的情况
							   //改变反向边的容量 
			u=p[u]; 
		}
	}
	return ans;
}
int main()
{
	scanf("%d%d%d",&n,&m,&d);
		memset(liu,0,sizeof(liu));
		for(int i=1;i<=n;i++){
			int x,y;
			scanf("%d%d",&x,&y);
			while(x--){
				int a;
				scanf("%d",&a);
				liu[0][a]=1;
				liu[a][n+m+d+i]=1;
				liu[n+m+d+i][2*(n+m+d)+i]=1;	
			}
			while(y--){
				int a;
				scanf("%d",&a);
				liu[2*(n+m+d)+i][3*(n+m+d)+a]=1;
				liu[3*(n+m+d)+a][4*(n+m+d)]=1;	
			}
		}
		printf("%d\n",EK_network(0,4*(n+m+d)));
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值