2019浙大研究生复试机试刷题解题报告——A1055

1055 The World’s Richest (25 分)
Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^5) - the total number of people, and K (≤10 ^3) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^​6​​ ,10​^6​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

“Name Age Net_Worth”

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意:

1.给出n个富豪的姓名、年龄、财产数
2.给出年龄范围,按规定格式输出该年龄范围内财产数最高的m个富豪的相关信息
3.如果没有符合要求的人,输出“None”
4.输出规则:按财产数由高到低输出,财产数相同的,按年龄非递减的顺序输出,年龄相同的,按姓名字典序输出。

思路:

  1. 查看排序规则,按要求容易写出排序规则的代码如下:
bool cmp(Rich a,Rich b)
{
     if(a.worths!=b.worths)
        return a.worths>b.worths;
     else if(a.age!=b.age)
        return a.age<b.age;
     else
        return strcmp(a.name,b.name)<0;
}
  1. 由于要保存每个人的信息,考虑使用结构体数组
typedef struct Rich
{
     char name[10];
     int age,worths;
}Rich;
  1. 按排序规则对数组进行排序
  2. 根据每组查询给出的年龄范围,枚举结构体数组,输出符合要求的富豪信息
  3. 枚举前要对数组进行预处理,否则在测试点2处会超时(方法:由题目中可注意到每组查询输出的人数m不超过一百,并且按财产从高到低的顺序排序的,所以如果遍历时发现某个年龄的人数超过100,则第100人之后的数据可以不用遍历,以提高查询效率)

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

typedef struct Richer
{
  char name[10];
  int age;
  int worths;
}Rich;

bool cmp(Rich a,Rich b)
{
  if(a.worths!=b.worths)
     return a.worths>b.worths;
  else if(a.age!=b.age)
     return a.age<b.age;
  else 
     return strcmp(a.name,b.name)<0;
}

int main()
{
  int n,k;
  scanf("%d%d",&n,&k);
  Rich init[n];
  int age[210]={0};
  for(int i=0;i<n;++i)
  {
    scanf("%s%d%d",init[i].name,&init[i].age,&init[i].worths);
  }
  sort(init,init+n,cmp);
  
  Rich valid[n];
  int validNum=0;
  for(int i=0;i<n;++i)
  {
    if(age[init[i].age]<100)
    {
      age[init[i].age]++;
      valid[validNum++]=init[i];
    }
  }
  
  for(int i=1;i<=k;++i)
  {
    printf("Case #%d:\n",i);
    int ageL,ageR,m,num=0;
    scanf("%d%d%d",&m,&ageL,&ageR);
    for(int j=0;j<validNum&&num<m;++j)
    {
      if(valid[j].age>=ageL&&valid[j].age<=ageR)
      {
        printf("%s %d %d\n",valid[j].name,valid[j].age,valid[j].worths);
        num++;
      }
      
    }
    if(num==0)printf("None");
  }
  
  return 0;
  
}

以上代码已通过测试

Atalanta 2019.2.18

  • 3
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值