HDU 5289 Assignment(2015 Multi-University Training Contest 1)

116 篇文章 0 订阅
7 篇文章 0 订阅

Assignment

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2976    Accepted Submission(s): 1385


Problem Description
Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.
 

Input
In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.
 

Output
For each test,output the number of groups.
 

Sample Input
  
  
2 4 2 3 1 2 4 10 5 0 3 4 5 2 1 6 7 8 9
 

Sample Output
  
  
5 28
Hint
First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3]
 

Author
FZUACM
 

Source
 
题意:给T足数据,然后每组一个n和k,表示n个数,k表示最大允许的能力差,接下来n个数表示n个人的能力,求能力差在k之内的区间有几个。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define LL __int64
const int MIN=1e9+10;
const int MAX=0;
const int maxm=1e5+10;
int a[maxm];
int mina[maxm];
int maxa[maxm];
int n,k;
void Init()
{
    for(int i=0;i<=maxm;i++)
    {
        mina[i]=MIN;
        maxa[i]=MAX;
    }
}
int lowbit(int i)
{
    return i&(-i);
}
void add(int i,int v)
{
    while(i<=n)
    {
        mina[i]=min(mina[i],v);
        maxa[i]=max(maxa[i],v);
        i+=lowbit(i);
    }
}
int quertymin(int i)
{
    int Min=MIN;
    while(i>0)
    {
        Min=min(Min,mina[i]);
        i-=lowbit(i);
    }
    return Min;
}
int quertymax(int i)
{
    int Max=MAX;
    while(i>0)
    {
        Max=max(Max,maxa[i]);
        i-=lowbit(i);
    }
    return Max;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        Init();
        scanf("%d%d",&n,&k);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        LL sum=0;
        for(int i=n;i>=1;i--)
        {
            add(i,a[i]);
            int low=i;
            int high=n;
            int p=0;
            while(low<=high)
            {
                int mid=(low+high)>>1;
                if(quertymax(mid)-quertymin(mid)<k)
                {
                    p=mid;
                    low=mid+1;
                }
                else
                {
                    high=mid-1;
                }
            }
            sum+=p-i+1;
        }
        printf("%I64d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值