hdu 5366 The mook jong 动态规划

The mook jong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 402    Accepted Submission(s): 306


Problem Description
![](../../data/images/C613-1001-1.jpg)

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).
 

Input
There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)
 

Output
Print the ways in a single line for each case.
 

Sample Input
  
  
1 2 3 4 5 6
 

Sample Output
  
  
1 2 3 5 8 12
 

Source

枚举最后放的位置,最后放的位置要求前两个位置没有放,所以累加0-i-3即可


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define ll long long
ll dp[80];
ll ans[80];
void work(int n){
    if(ans[n] != -1) return ;
    memset(dp,0,sizeof(dp));
    dp[0] = 1,dp[1] = 1,dp[2] = 1;
    for(int i = 3;i <= n;i++){
        for(int j = i-3;j>=0;j--)
            dp[i] += dp[j];
    }
    ans[n] = 0;
    for(int i = 1;i <= n; i++)
        ans[n] += dp[i];
}
int main(){
    int n;
    memset(ans,-1,sizeof(ans));
    while(scanf("%d",&n)!=EOF){
        work(n);
        cout<<ans[n]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值