Hdu5366 The mook jong

Problem Description

ZJiaQ want to become a strong man, so he decided to play the mook jong。ZJiaQ want to put some mook jongs in his backyard. His backyard consist of n bricks that is 1*1,so it is 1*n。ZJiaQ want to put a mook jong in a brick. because of the hands of the mook jong, the distance of two mook jongs should be equal or more than 2 bricks. Now ZJiaQ want to know how many ways can ZJiaQ put mook jongs legally(at least one mook jong).

Input

There ar multiply cases. For each case, there is a single integer n( 1 < = n < = 60)

Output

Print the ways in a single line for each case.

Sample Input

1
2
3
4
5
6

Sample Output

1
2
3
5
8
12


分别用a[i],b[i]表示总共位置数为i时,最后一个含桩和不含桩的种数,那么所求结果即为a[i]+b[i];
对于b[i],由于其第i个位置前面情况可以任意,故b[i]=a[i-1]+b[i-1];
而对于a[i],只需第i-2、i-1个位置为空;
同时考虑到以该方法计算时,会遗漏前面全为0的情况,故在加一即可,即a[i]=b[i-2]+1。


#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n,i;
    long long a[65],b[65];
    b[1]=0;
    b[2]=1;
    b[3]=2;
    a[1]=1;
    a[2]=1;
    a[3]=1;
    for(i=4;i<61;i++){
        a[i]=b[i-2]+1;
        b[i]=b[i-1]+a[i-1];
    }
    while(~scanf("%d",&n)){
        printf("%lld\n",a[n]+b[n]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值