hdu 5475 An easy problem 线段树

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 746    Accepted Submission(s): 427


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 

Source


用线段树维护区间乘积即可。删除操作就是把数字置为1.


#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<map>
using namespace std;
#define maxn 300007
int M;
int num[maxn],lc[maxn],rc[maxn],cnt;
void build(int u,int l,int r){
    num[u] = 1;
    if(l == r) return ;
    int mid = (l+r)/2;
    lc[u] = ++cnt;
    rc[u] = ++cnt;
    build(lc[u],l,mid);
    build(rc[u],mid+1,r);
}

void add(int u,int l,int r,int p,int val){
    if(l == r){
        num[u] = val;
        return ;
    }
    int mid = (l+r)/2;
    if(p > mid) add(rc[u],mid+1,r,p,val);
    else add(lc[u],l,mid,p,val);
    num[u] = ((long long)num[lc[u]]*num[rc[u]])%M;
}

int main(){
    int t,n,tt=1,u,v;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&M);
        cnt = 0;
        build(0,0,n-1);
        printf("Case #%d:\n",tt++);
        for(int i = 0;i < n; i++){
            scanf("%d%d",&u,&v);
            if(u == 1)
                add(0,0,n-1,i,v);
            else
                add(0,0,n-1,v-1,1);
            printf("%d\n",num[0]%M);
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GDRetop

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值