Wall——凸包模板问题

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King’s castle. The King was so greedy, that he would not listen to his Architect’s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
在这里插入图片描述
Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King’s requirements.

The task is somewhat simplified by the fact, that the King’s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle’s vertices in feet.
 

Input
The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King’s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle’s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output
Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King’s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output
1628

Hint
结果四舍五入就可以了

题意:求得n个点的凸包后,然后求与凸包相距为L的外圈的周长。
 
思路:画图后可知,最后所求的周长就是等于凸包周长+半径为L的圆的周长。
 
附图片一张(转载):
在这里插入图片描述
AC代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX = 1017;
const double pi = 3.1415926535897932384626;
double EPS = 1e-10;

double add(double a,double b)
{
    if(abs(a+b) < EPS * (abs(a) + abs(b))) return 0;
    return a+b;
}

struct P
{
    double x,y;
    P() {}
    P(double x,double y) : x(x), y(y) {}
    P operator + (P p)
    {
        return P(add(x,p.x),add(y,p.y));
    }
    P operator - (P p)
    {
        return P(add(x,-p.x),add(y,-p.y));
    }
    P operator * (double d)
    {
        return P(x*d,y*d);
    }
    double dot (P p)
    {
        return add(x*p.x,y*p.y);
    }
    double det (P p)
    {
        return add(x*p.y,-y*p.x);
    }
};

double dist(P a,P b)
{
    return sqrt((a-b).dot(a-b));
}

bool cmp_x(const P& p,const P& q)
{
    if(p.x != q.x) return p.x < q.x;
    return p.y < q.y;
}

// 求凸包
vector<P> convex_hull(P *ps,int n)
{
    sort(ps,ps+n,cmp_x);
    int k = 0;
    vector<P> qs(n*2);
    // 构造凸包下侧
    for(int i=0;i<n;i++)
    {
        while(k>1 && (qs[k-1]-qs[k-2]).det(ps[i] - qs[k-1]) <= 0) k--;
        qs[k++] = ps[i];
    }

    // 构造凸包上侧
    for(int i = n-2, t = k; i>=0;i--)
    {
        while(k > t && (qs[k-1]-qs[k-2]).det(ps[i] - qs[k-1]) <= 0) k--;
        qs[k++] = ps[i];
    }
    qs.resize(k-1);
    return qs;
}

int main()
{
    int n,l;
    P ps[MAX];
    scanf("%d%d",&n,&l);
    for(int i=0;i<n;i++)
        scanf("%lf%lf",&ps[i].x,&ps[i].y);

    vector<P> qs = convex_hull(ps,n);
    double res=0.0;
    for(int i = 1;i<qs.size();i++)
        res += dist(qs[i],qs[i-1]);
    res += dist(qs[0],qs[qs.size()-1]);
    res += 2*pi*l;
    printf("%.0lf",res);
    return 0;
}

  之前求距离的时候把dist函数命名为distance了,而且还习惯性的在开头写上了using namespace std;这句话,结果就是distance函数和std::distance冲突了,然后编译一直报错。。。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值