wall(凸包模板练习)

 

描述 Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 


Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

输入

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

There are multi test cases.EOF will terminate the input.

输出

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

样例输入

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

样例输出

1628

题目大意:国王要建墙,要求长度最短且墙与房的距离不得小于L,给出房区坐标,求最短长度的墙。

 

思路:房区是一个多边形,要使围起来最短,凸包算法确定,但因为要保持距离围,会存在弯曲角。需要另行计算。

 

可得,最短周长是凸包周长加一个半径为L的圆周长和。(为什么是一个圆的距离?保证了凸包,多边形外角和为360度)

 

代码如下:

 
#include<stdio.h>
#include<math.h>
#include<algorithm>
#define pi 3.1415926
using namespace std;
int n,L,top;
struct point 
{	
	int x,y;
}p[1005],s[1005],t;
double cross(point t1,point t2,point t3,point t4)  //求向量t1.t2和向量t3.t4的叉积
{	
	return (t2.x-t1.x)*(t4.y-t3.y)-(t2.y-t1.y)*(t4.x-t3.x);
}
double dis(point t1,point t2)   //求距离
{
	double z=(t2.x-t1.x)*(t2.x-t1.x)+(t2.y-t1.y)*(t2.y-t1.y);
	return sqrt(z);
}
bool cmp(point t1,point t2)
{	
	double z=cross(p[0],t1,p[0],t2);
	return z?z>0:dis(p[0],t1)>dis(p[0],t2);
 }
void findpoint()    //找基点,按y从小到大,如果y相同,按x从左到右
{   int i,j=0;	
    t=p[0];
	for(i=1;i<n;i++)
	{	
		if(t.y>p[i].y||(t.y==p[i].y&&t.x>p[i].x))	
		{		
			j=i;		
			t=p[i];	
		}
	}
	t=p[0];	
	p[0]=p[j];
	p[j]=t;
}
void scanner()
{	
	int i;
	findpoint();
	sort(p+1,p+n,cmp);
	s[0]=p[0];
	s[1]=p[1];
	top=1;	
	for(i=2;i<n;i++)
	{	
		while(cross(s[top-1],s[top],s[top],p[i])<0)	
			top--;	
		top++;	
		s[top]=p[i];
	}
}
int main()
{	
	int i;
	double ans;
	while(~scanf("%d%d",&n,&L))	
	{	
		for(i=0;i<n;i++)
		{	
			scanf("%d%d",&p[i].x,&p[i].y);	
		}	
		scanner();	
		ans=2*pi*L;	
		for(i=0;i<=top;i++)	
		{			
			ans+=dis(s[i],s[(i+1)%(top+1)]);
		}	
		printf("%.0lf\n",ans);
	}
	return 0;
}
                

 

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值