实验10-1 圆形体体积计算器 (20分)

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

球体体积 V=​(3/4)πr​3,其中r是球体半径。
圆柱体体积 V=πr2h,其中r是底圆半径,h是高。
圆锥体体积 V=(1/3)πr2h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
然后从标准输入读进一个整数指令。

输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。

输入样例:
1
2
3
2.4 3
0
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
题目集全集传送门

#include <stdio.h>
#include <stdlib.h>    //包含exit()函数
#define PI 3.141592653579    //π

void menu();    //菜单栏
double ball(double r);    //V-球
double cylinder(double r, double h);    //V-圆柱
double cone(double r, double h);    //V-圆锥

int main()
{
    int n;
    double r, h;
    while (1)
    {
        menu();
        scanf("%d", &n);
        switch (n)
        {
        case 1:
            printf("Please enter the radius:\n");
            scanf("%lf", &r);
            printf("%.2lf\n", ball(r));
            break;
        case 2:
            printf("Please enter the radius and the height:\n");
            scanf("%lf %lf", &r, &h);
            printf("%.2lf\n", cylinder(r, h));
            break;
        case 3:
            printf("Please enter the radius and the height:\n");
            scanf("%lf %lf", &r, &h);
            printf("%.2lf\n", cone(r, h));
            break;
        default:
            exit(0);    //直接退出
        }
    }

    return 0;
}
void menu()
{
    printf("1-Ball\n");
    printf("2-Cylinder\n");
    printf("3-Cone\n");
    printf("other-Exit\n");
    printf("Please enter your command:\n");
}
double ball(double r)
{
    return ((double)4 / 3) * PI * r * r * r;
}
double cylinder(double r, double h)
{   
    return PI * r * r * h;
}
double cone(double r, double h)
{    
    return ((double)1 / 3) * PI * r * r * h;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Re:从零开始的代码生活

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值