ACMSTEP 1.2.2 A+B Coming //超级水题 控制格式输入输出(CC++)


A+B Coming

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 880 Accepted Submission(s): 443
Problem Description
Many classmates said to me that A+B is must needs.
If you can’t AC this problem, you would invite me for night meal. ^_^

Input
Input may contain multiple test cases. Each case contains A and B in one line.
A, B are hexadecimal number.
Input terminates by EOF.

Output
Output A+B in decimal number in one line.

Sample Input
1 9

A B

a b


Sample Output
10

21

21



没什么难度主要是scanf和printf的输入输出格式。
C++中也有,主要用控制流输入输出来实现,具体如下(需要头文件iomanip

dec 置基数为10
  hex 置基数为16
  oct 置基数为8
  setfill(c) 设填充字符为c
  setprecision(n) 设显示小数精度为n位
  setw(n) 设域宽为n个字符
  setiosflags(ios::fixed) 固定的浮点显示
  setiosflags(ios::scientific) 指数表示
  setiosflags(ios::left) 左对齐
  setiosflags(ios::right) 右对齐
  setiosflags(ios::skipws) 忽略前导空白
  setiosflags(ios::uppercase)16进制数大写输出
  setiosflags(ios::lowercase)16进制数小写输出




#include <cstdio>

#include <cstdlib>
using namespace std;
int main()
{
	int a, b;
	while (scanf("%x %x",&a, &b)!=EOF)
	{
		printf("%d\n",a+b);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值