Uva11520 - Fill the Square

In this problem, you have to draw a square using uppercase English Alphabets.
To be more precise, you will be given a square grid with some empty blocks and others already lled
for you with some letters to make your task easier. You have to insert characters in every empty cell
so that the whole grid is lled with alphabets. In doing so you have to meet the following rules:
1. Make sure no adjacent cells contain the same letter; two cells are adjacent if they share a common
edge.
2. There could be many ways to ll the grid. You have to ensure you make the lexicographically
smallest one. Here, two grids are checked in row major order when comparing lexicographically.
Input
The rst line of input will contain an integer that will determine the number of test cases. Each case
starts with an integer n (n 10), that represents the dimension of the grid. The next n lines will
contain n characters each. Every cell of the grid is either a `.' or a letter from [A, Z]. Here a `.'
represents an empty cell.
Output
For each case, rst output `Case #:' (# replaced by case number) and in the next n lines output the
input matrix with the empty cells lled heeding the rules above.
Sample Input
2
3
...
...
...
3
...
A..
...
Sample Output
Case 1:
ABA
BAB
ABA
Case 2:
BAB
ABA
BAB

#include <iostream>
#include <cstring>
using namespace std;
const int MAXN = 15;
int n;
char mp[MAXN][MAXN];
void change(int &x, int &y)
{
    y++;
    if(y>n)
    {
        x++;
        y=1;
    }
}
bool dfs(int x,int y)
{
    if(x==n+1)return true;
    if(mp[x][y]!='.')
    {
        change(x,y);
        if(dfs(x,y))return true;
    }else{
          for(int i='A'; i<='Z'; i++)
          {
            if(mp[x-1][y]!=i&&mp[x+1][y]!=i&&mp[x][y+1]!=i&&mp[x][y-1]!=i)
            {
                mp[x][y] = i;
                int x1 = x,y1 = y;
                change(x1,y1);
                if(dfs(x1,y1))return true;
                mp[x][y] ='.';
            }
          }
    }
    return false;
}
int main()
{
    int t, cs;
    cin>>t;
    for(cs=1; cs<=t; cs++)
    {   
        cin>>n;
        memset(mp,0,sizeof (mp));
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                cin>>mp[i][j];
            }
        }
        dfs(1,1);
        cout<<"Case "<<cs<<":"<<endl;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                cout<<mp[i][j];
            }cout<<endl;
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值