SDJZU_新生_贪心
27:25:42
30:00:00
Current Time: | 2015-01-24 18:55:42 | Contest Type: | Private |
Start Time: | 2015-01-23 15:30:00 | Contest Status: | Running |
End Time: | 2015-01-24 21:30:00 | Manager: | ACboy |
|
|
ID
|
Title
|
---|---|---|---|
19 / 53 | Problem A | 今年暑假不AC | |
2 / 38 | Problem B | Fence Repair | |
18 / 38 | Problem C | FatMouse' Trade | |
9 / 23 | Problem D | Doing Homework again | |
2 / 6 | Problem E | Wooden Sticks | |
Problem F | lines |
nickname改成自己真实姓名
C - FatMouse' Trade
Crawling in process...
Crawling failed
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
Sample Output
13.333 31.500
#include<stdio.h>
#include<algorithm>
using namespace std;
struct A
{
int j,f;
double z;
}a[1007];
int cmp(A a,A b)
{
return a.z>b.z;
}
int main()
{
int M,N;
while(scanf("%d%d",&M,&N)!=EOF)
{
if(M==-1&&N==-1)
{
break;
}
A a[1007];
int i;
for(i=0;i<N;i++)
{
scanf("%d%d",&a[i].j,&a[i].f);
a[i].z=((double)a[i].j/a[i].f);
}
sort(a,a+N,cmp);
double b=0;
for(i=0;M>0&&i<N;i++)
{
if(M>=a[i].f)
{
M-=a[i].f;
b+=a[i].j;
}
else
{
b+=(((double)M/a[i].f)*a[i].j);
M=0;
}
}
printf("%.3f\n",b);
}
return 0;
}
Submit
Problem: | |
Language: | |
Public: |
Rank Setting