SDJZU_新生_贪心_Doing Homework again

昨天就是练练手,培训今天才开始
SDJZU_新生_贪心
27:28:20
30:00:00
Current Time: 2015-01-24 18:58:19Contest Type: Private
Start Time: 2015-01-23 15:30:00Contest Status: Running
End Time: 2015-01-24 21:30:00Manager: ACboy
nickname改成自己真实姓名
D - Doing Homework again
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output

For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input

       
       
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output

       
       
0 3 5

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct A
{
    int time,grade;
}a[1007];
int cmp(A a,A b)
{
    if(a.grade==b.grade)
    {
        return a.time<b.time;
    }
    return a.grade>b.grade;
}
int main()
{
    A a[1007];
    int T,i;
    scanf("%d",&T);
    while(T--)
    {
        int N,sum=0,b[1007],c,d;
        scanf("%d",&N);
        for(i=0;i<N;i++)
        {
            scanf("%d",&a[i].time);
        }
        for(i=0;i<N;i++)
        {
            scanf("%d",&a[i].grade);
        }
        sort(a,a+N,cmp);
        memset(b,0,sizeof(b));
        for(i=0;i<N;i++)
        {
            int f;
            c=a[i].time;
            if(b[c]==0)
            {
                b[c]=a[i].grade;
            }
            else
            {
                for(d=c;d>0;d--)
                {
                    f=0;
                    if(b[d]==0)
                    {
                        f=1;
                        b[d]=a[i].grade;
                        break;
                    }
                }
                if(f==0)
                {
                    sum+=a[i].grade;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


Submit

Problem:
Language:
Public:
        Rank Setting
        • 0
          点赞
        • 0
          收藏
          觉得还不错? 一键收藏
        • 0
          评论
        提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

        “相关推荐”对你有帮助么?

        • 非常没帮助
        • 没帮助
        • 一般
        • 有帮助
        • 非常有帮助
        提交
        评论
        添加红包

        请填写红包祝福语或标题

        红包个数最小为10个

        红包金额最低5元

        当前余额3.43前往充值 >
        需支付:10.00
        成就一亿技术人!
        领取后你会自动成为博主和红包主的粉丝 规则
        hope_wisdom
        发出的红包
        实付
        使用余额支付
        点击重新获取
        扫码支付
        钱包余额 0

        抵扣说明:

        1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
        2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

        余额充值