SDJZU_新生_栈和队列
24:00:00
Current Time: | 2015-01-26 11:03:41 | Contest Type: | Private |
Start Time: | 2015-01-24 21:59:00 | Contest Status: | Ended |
End Time: | 2015-01-25 21:59:00 | Manager: | ACboy |
|
|
ID
|
Origin
|
Title
|
---|---|---|---|---|
23 / 45 | Problem A | HDU 1870 | 愚人节的礼物 | |
15 / 42 | Problem B | HDU 1276 | 士兵队列训练问题 | |
8 / 16 | Problem C | HDU 1702 | ACboy needs your help again! | |
13 / 55 | Problem D | HDU 1022 | Train Problem I | |
0 / 1 | Problem E | HDU 1237 | 简单计算器 | |
2 / 6 | Problem F | HDU 1873 | 看病要排队 | |
1 / 1 | Problem G | HDU 1896 | Stones | |
Problem H | HDU 1871 | 无题 |
还有几个人的nickname没改过来呢
B - 士兵队列训练问题
Crawling in process...
Crawling failed
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
某部队进行新兵队列训练,将新兵从一开始按顺序依次编号,并排成一行横队,训练的规则如下:从头开始一至二报数,凡报到二的出列,剩下的向小序号方向靠拢,再从头开始进行一至三报数,凡报到三的出列,剩下的向小序号方向靠拢,继续从头开始进行一至二报数。。。,以后从头开始轮流进行一至二报数、一至三报数直到剩下的人数不超过三人为止。
Input
本题有多个测试数据组,第一行为组数N,接着为N行新兵人数,新兵人数不超过5000。
Output
共有N行,分别对应输入的新兵人数,每行输出剩下的新兵最初的编号,编号之间有一个空格。
Sample Input
2 20 40
Sample Output
1 7 19 1 19 37
#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
return a<b;
}
int main()
{
int n;
scanf("%d",&n);
while (n--)
{
queue <int> s;
int b,i,k,j;
scanf("%d",&b);
for(i=1;i<=b;i++)
{
s.push(i);
}
while(b>3)
{
k=b;
for(j=1;j<=k;j++)
{
if(j%2==0)
{
s.pop();b--;
}
else
{
s.push(s.front());
s.pop();
}
}
if(b<4) break;
for(j=1,k=b;j<=k;j++)
{
if(j%3==0)
{
s.pop();b--;
}
else
{
s.push(s.front());
s.pop();
}
}
}
int c[7];
for(i=0;i<b;i++)
{
c[i]=s.front();
s.pop();
}
sort(c,c+b,cmp);
for(i=1;i<=b;i++)
{
printf("%d",c[i-1]);
if(i!=b)
{
printf(" ");
}
else{printf("\n");}
}
}
return 0;
}
Submit
Problem: | |
Language: | |
Public: |
Rank Setting