SDJZU_新生_排序
2:43:03
15:00:00
Current Time: | 2015-01-26 11:21:03 | Contest Type: | Private |
Start Time: | 2015-01-26 08:38:00 | Contest Status: | Running |
End Time: | 2015-01-26 23:38:00 | Manager: | ACboy |
D - sort
Crawling in process...
Crawling failed
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Description
给你n个整数,请按从大到小的顺序输出其中前m大的数。
Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
Output
对每组测试数据按从大到小的顺序输出前m大的数。
Sample Input
5 3 3 -35 92 213 -644
Sample Output
213 92 3
Hint
Hint 请用VC/VC++提交
#include<stdio.h>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
return a>b;
}
int main()
{
int m,n;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,a[519000];
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}//printf("dji");
sort(a,a+n,cmp);
for(i=0;i<m;i++)
{
printf("%d",a[i]);
if(i!=m-1)
{
printf(" ");
}
}
printf("\n");
}
return 0;
}
Rank Setting