SDJZU_新生_背包_HDU 2602 Bone Collector

Bone Collector
Crawling in process... Crawling failed Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

     
     
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

     
     
14
       
  
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    while (n--)
    {
        int N,V;
        scanf("%d%d",&N,&V);
        int i,j,k,m,vi[10007],wi[10007],dp[10007];
        memset(dp,0,sizeof(dp));
        for(i=1;i<=N;i++)
        {
            scanf("%d",&wi[i]);
        }
        for(i=1;i<=N;i++)
        {
            scanf("%d",&vi[i]);
        }
        for(i=1;i<=N;i++)
        {
            for(j=V;j>=vi[i];j--)
            {
                dp[j]=max(dp[j],dp[j-vi[i]]+wi[i]);
            }
        }
        printf("%d\n",dp[V]);
    }
    return 0;
}


/*调了好多遍,最后我雨给我又调了一遍,发现一开始看错题意了。*/
/*下面是用结构体做的,原理一样,只不过用上了结构体而且删除了c++的部分。*/

#include<stdio.h>
#include<string.h>
int dp[1007];
struct sa
{
    int W,V;
}data[1007];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int n,v;
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
        scanf("%d",&data[i].W);
        for(j=1;j<=n;j++)
        scanf("%d",&data[j].V);
        for(i=1;i<=n;i++)
        for(j=v;j>=data[i].V;j--)
        {
            dp[j]=max(dp[j],dp[j-data[i].V]+data[i].W);
        }
        printf("%d\n",dp[v]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值