一道简单dfs 之坑缠我半天

F - Don’t Get Rooked
In chess, the rook is a piece that can move any number of squares vertically or horizontally. In this problem we will consider small chess boards (at most 4x4) that can also contain walls through which rooks cannot move. The goal is to place as many rooks on a board as possible so that no two can capture each other. A configuration of rooks is legal provided that no two rooks are on the same horizontal row or vertical column unless there is at least one wall separating them.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of rooks in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

Your task is to write a program that, given a description of a board, calculates the maximum number of rooks that can be placed on the board in a legal configuration.
Input
The input contains one or more board descriptions, followed by a line containing the number 0 that signals the end of the file. Each board description begins with a line containing a positive integer n that is the size of the board; n will be at most 4. The next n lines each describe one row of the board, with a ‘.’ indicating an open space and an uppercase ‘X’ indicating a wall. There are no spaces in the input.
Output
For each test case, output one line containing the maximum number of rooks that can be placed on the board in a legal configuration.
Sample Input
4
.X…

XX…

2
XX
.X
3
.X.
X.X
.X.
3

.XX
.XX
4




0
Sample Output
5
1
5
2
4

/*
4
.X..
....
XX..
....
*/
#include<stdio.h>
#include<string>
#include<queue>
#include<iostream>
#include<string.h>
#define N 200005
using namespace std;
char maps[4][4];
bool vis[4][4];int ans=0,n;
int judge(int x,int y)
{
    if(vis[x][y]==1||maps[x][y]=='X') return 0;
    for(int i=x-1;i>=0;i--) if(maps[i][y]=='X') break;else if(vis[i][y]==1) return 0;
    for(int j=y-1;j>=0;j--) if(maps[x][j]=='X') break;else if(vis[x][j]==1) return 0;
    return 1;
}
void dfs(int pos,int cur)
{

    for(int i=pos;i<n*n;i++)
    {
        int x=i/n;//这里和以下几处把应该的i写成了pos,找错找了半天,真™的吐了
        int y=i%n;//还有这

        if(judge(x,y))
        {

            vis[x][y]=1;
            ans=max(ans,cur+1);
            dfs(i+1,cur+1);//还有这 这里不应该是dfs(pos+1,cur+1);
            vis[x][y]=0;
        }
    }
}
int main()
{

    while(1)
    {
        scanf("%d",&n);
        getchar();
        if(!n) break;
        memset(vis,0,sizeof(vis));
        ans=0;
        for(int i=0;i<n;i++)
            {
                for(int j=0;j<n;j++) scanf("%c",&maps[i][j]);
                getchar();
            }

        dfs(0,0);
        printf("%d\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值