Stars(树状数组)

Stars

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 6 Accepted Submission(s) : 4
Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5

Sample Output
  
  
1 2 1 1 0

Source
Ural Collegiate Programming Contest 1999
 
 
题意:天文学家经常观察星象图。星象图中用平面上的点来表示一颗星星,每一颗星星都有一个笛卡尔坐标。设定星星的等级为其左下角星星的总数。天文学家们想知道星星等级的分布情况。比如上图,5号星星的等级为3(其左下角有编号为1、2、4的星星共三颗)。2号星星和4号星星的等级为1。在上图中只有一颗星星等级为0,两颗星星等级为1,一颗星星等级为2,一颗星星等级为3。
给定一个星象图,请你写一个程序计算各个等级的星星数目。输入的第一行包含星星的总数N (1<=N<=15000)。接下来N行,描述星星的坐标(X,Y)(X和Y用空格分开,0<=X,Y<=32000)。星象图中的每个点处最多只有一颗星星。所有星星按Y坐标升序排列。Y坐标相等的星星按X坐标升序排列。
 
题解:树状数组,由于Y坐标按升序,模拟题意即可忽略,所有点只看x坐标即可,给出(x,y)只要求1~~x的和即可、一开始一直在纠结题目中要求是左下角的星星个数,那么正下方的值怎么解决...如果前面出现(1,2)后面出现(1,3)那取出getsum的值是否会是一样的...后来才想明白 当前边出现(1,2)时,更新时num[1]++,即后边再出现
(1,3)时getsum的值已经是出现(1,2)值+1
#include<cstdio>
#include<cstring>
using namespace std;
const int M=32002;
#define lowbit(x) (x)&(-x)
int num[M];
void update(int x)
{
    for(;x<=M;x+=lowbit(x)) num[x]++;
}
int getsum(int x)
{
    int t=0;
    for(;x>0;x-=lowbit(x)) t+=num[x];
    return t;
}
int main()
{
    int n,i,x,y,res[M];
    while(scanf("%d",&n)!=EOF)
    {
        memset(res,0,sizeof(res));
        memset(num,0,sizeof(num));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&x,&y);
            x++;
            res[getsum(x)]++;
            update(x);
        }
        for(i=0;i<n;i++)
         printf("%d\n",res[i]);
    }
    return 0;
}

 
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值