Stars(树状数组)

Stars
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 30828  Accepted: 13471

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

      题意:

      给出 N(1 ~ 15000) ,后给出 N 个 x 和 y 的坐标 [ 0 ~ 32000 ],输入的顺序是以 y 递增的顺序输入的,如果 y 相等,则按 x 递增的顺序输入。每个星星都有一个等级,这个等级等于左下所有星星的数量。输出 0 ~ N - 1 每个等级各含多少颗星星。

 

      思路:

      树状数组。

      每个星星一给出就可以确定定出等级,因为根据输入的顺序可以得出后面给出的星星是不会影响这颗星星的等级的,所以边输入就可以边统计。等级就是 0 ~ xi 总共含有的星星数量。用树状数组统计算出登记后,再将 xi 添加到数组中即可。有一个注意的地方就是,如果 x == 0 的时候会出现死循环而 TLE ,是因为 add 操作,所以应该要对 x 坐标 + 1 处理。

 

      AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int bit[32005], ran[15005];

void add(int i, int x) {
        while (i <= 32005) {
                bit[i] += x;
                i += i & -i;
        }
}

int sum(int i) {
        int s = 0;
        while (i > 0) {
                s += bit[i];
                i -= i & -i;
        }
        return s;
}

int main () {
        int n;
        scanf("%d", &n);

        memset(bit, 0, sizeof(bit));
        memset(ran, 0, sizeof(ran));

        for (int i = 0; i < n; ++i) {
                int x, y;
                scanf("%d%d", &x, &y);
                ++x;
                ++ran[ sum(x) ];
                add(x, 1);
        }

        for (int i = 0; i < n; ++i)
                printf("%d\n", ran[i]);

        return 0;
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值