A Famous Music Composer(map)

9 篇文章 0 订阅

A Famous Music Composer

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 560 Accepted Submission(s): 334


Problem Description
Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:


Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.

In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:


Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

Input
Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).

Output
For each case output the required answer, following the format of the sample.

Sample Input
  
  
Ab minor D# major G minor

Sample Output
  
  
Case 1: G# minor Case 2: Eb major Case 3: UNIQUE

Source

题意:给出12中情况所对应的结果、又给出5种情况(返回前12种中对应的结果)
      输入两个字符串,第一个字符返回对应结果,若结果为空则输出UNIQUE,第二个字符串不变
#include<iostream>
#include<map>
using namespace std;
int main()
{
    map<string,string> m;
    m["A#"]="Bb"; m["C#"]="Db";
    m["D#"]="Eb"; m["F#"]="Gb";
    m["G#"]="Ab"; m["Ab"]="G#";
    m["Gb"]="F#"; m["Db"]="C#";
    m["Bb"]="A#"; m["Eb"]="D#";
    int i=1;
    string a,b;
    while(cin>>a>>b)
    {
        cout<<"Case "<<i++<<": ";
        if(m[a]=="")
         cout<<"UNIQUE"<<endl;
        else
         cout<<m[a]<<" "<<b<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值