PAT(A) - 1058. A+B in Hogwarts (20)


1058. A+B in Hogwarts (20)

时间限制
50 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28

思路分析:一个金额计算问题,我的做法是统一换算成最小的单位,例如计算时间的时候,统一把小时、分钟都换成秒为单位的量。刚开始我整数类型用的int,有一个测试点不对,后来发现是数据溢出了,改成long long 就AC了。


#include <iostream>

using namespace std;

typedef struct {
    long long g;
    long long s;
    long long k;
} Money;

int main() {
    //freopen( "123.txt", "r", stdin );
    Money a, b, c;
    scanf( "%lld.%lld.%lld", &a.g, &a.s, &a.k );
    scanf( "%lld.%lld.%lld", &b.g, &b.s, &b.k );

    long long sum_a = a.g * 17 * 29 + a.s * 29 + a.k;
    long long sum_b = b.g * 17 * 29 + b.s * 29 + b.k;
    long long sum_c = sum_a + sum_b;

    c.g = sum_c / ( 17 * 29 );
    c.s = ( sum_c - ( c.g * 17 * 29 ) ) / 29;
    c.k = sum_c - c.g * ( 17 * 29 ) - c.s * 29;

    printf( "%lld.%lld.%lld", c.g, c.s, c.k );
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值