PAT(A) - 1030. Travel Plan (30)


A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

思路分析:我用的DFS,网上大家用的都是Dijkstra,加栈记录路径。(主要是我Dijkstra写的还不是很熟练......)这道题测试数据很弱,相当弱。另外我发现PAT能过,牛客上的不能过,最小值是正确的,但是路径不对。我写的还是有问题吧,,先贴上来再说。。


#include <cstdio>
#include <vector>
#include <cstring>

#define MAX 500

using namespace std;

int MGraph[MAX][MAX];   // 图
int dist[MAX][MAX];     // 边的路长
int cost[MAX][MAX];     // 花费
int visit[MAX]; 
    
int minDist;            // 最短路径
int minCost;            // 最小花费

vector<int> path;       // 最后要输出的路径的数组
vector<int> temp;       // 中间记录路径的临时数组

void InsertEdge( int a, int b ) {   // 插入边
    MGraph[a][b] = 1;
    MGraph[b][a] = 1;
}

// DFS搜索
void DFS( int curNode, int end, int n, int d, int c ) {
    if( curNode == end ) {  // 找到路径
        if( d < minDist ) { // 更新结果
            minDist = d;
            minCost = c;
            path = temp;
        }
        else if( d == minDist ) {
            if( c < minCost ) {
                minCost = c;
                path = temp;
            }
        }
        temp.clear();       // 临时数组清空
        //printf( "\n" );
        return;
    }

    if( d > minDist ) { // 剪枝
        temp.clear();
        //printf( "\n" );
        return;
    }

    for( int i = 0; i < n; i++ ) {
        if( !visit[i] && MGraph[curNode][i] == 1 ) {
            visit[i] = 1;
            //printf( "%d ", i );
            temp.push_back( i );
            DFS( i, end, n, d + dist[curNode][i], c + cost[curNode][i] );
            visit[i] = 0;
        }
    }
}

int main() {
    //freopen( "123.txt", "r", stdin );
    int N, M, S, D;
    scanf( "%d%d%d%d", &N, &M, &S, &D );

    int a, b, d, w;
    for( int i = 0; i < M; i++ ) {
        scanf( "%d%d%d%d", &a, &b, &d, &w );
        InsertEdge( a, b );
        dist[a][b] = d;
        dist[b][a] = d;
        cost[a][b] = w;
        cost[b][a] = w;
    }

    minDist = minCost = 0x3ffffff;  // 更开始赋值一个很大的数
    visit[S] = 1;
    DFS( S, D, N, 0, 0 );
    printf( "%d", S );
    for( int i = 0; i < path.size(); i++ ) {
        printf( " %d", path[i] );
    }
    printf( " %d %d", minDist, minCost );

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值