PAT(A) - 1096. Consecutive Factors (20)


Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7


思路分析: 一个分解因子的问题,要去找出最长的连续因子。我的做法是从2开始遍历(题目说1除外),依次判断当前数组能否被N整除,边找边记录连续因子的长度,如果整除不尽,找到第一个因子的位置,我的程序里是head = j - curLen + 1,j为当前整除不尽的因子,curLen为当前连续因子的长度,所以head就出来了。最后输出连续因子的长度。如果最后这个数只能被自身整除,那就输出它自己。


#include <cstdio>
#include <cmath>

int main() {
    int n;
    scanf( "%d", &n );

    int sqr = (int)sqrt( n );
    int maxLen = 0;
    int head = 0;

    for( int i = 2; i <= sqr; i++ ) {
        int curLen = 0;
        int temp = 1;
        int j = i;

        while( 1 ) {
            temp = temp * j;
            if( n % temp == 0 ) {
                curLen++;
                if( curLen > maxLen ) {
                    maxLen = curLen;
                    head = j - curLen + 1;
                }
            }
            else {
                break;
            }
            j++;
        }
    }

    if( head == 0 ) {
        printf( "1\n%d", n );
        return 0;
    }
    printf( "%d\n", maxLen );
    for( int i = head; i < maxLen + head; i++ ) {
        if( i == head ) printf( "%d", i );
        else printf( "*%d", i );
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值