PAT(A) - 1146. Topological Order (25)

1146. Topological Order (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (<= 1,000), the number of vertices in the graph, and M (<= 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (<= 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4

这道题好像是18年浙大CS专业的研究生机试题,PAT考纲里说过有拓扑排序,但一直没考过,研究生复试题考出来了。

题意就是给你一个有向图,然后给出K个序列,让你判断每个序列是否为这个图的拓扑序。

其实只要会写生成拓扑排序的代码,就能理解拓扑序是怎么来的了。

思路分析:拓扑排序是先给图里的每个节点统计入度值,然后依次选择入度为0的节点加入到序列中,直到所有结点选择完毕,生成的这个序列就是拓扑序列。因为同一时刻可能有多个节点的入度都是0(例如样例的图,刚开始节点1和5的入度都是0),所以可能有多个拓扑序列。如果你发现某一时刻不存在入度为0的节点了,说明这个图存在环(这个题没考这个点,题目输入保证合法)。

#include <cstdio>
#include <vector>

#define MAX 1000 + 10

using namespace std;

int n, m;
vector<int> MGraph[MAX];
vector<int> ans;
int inDegree[MAX];
int tempDegree[MAX];

void copyDegree() {
    for( int i = 0; i < MAX; i++ ) tempDegree[i] = inDegree[i];
}

bool topSort( vector<int> &vec ) {
    for( int i = 0; i < vec.size(); i++ ) {
        int v = vec[i];
        if( tempDegree[v] == 0 ) {
            for( int j = 0; j < MGraph[v].size(); j++ ) {
                int u = MGraph[v][j];
                tempDegree[u]--;
            }
        }
        else return false;
    }
    return true;
}

int main() {
    scanf( "%d%d", &n, &m );
    for( int i = 0; i < m; i++ ) {
        int a, b;
        scanf( "%d%d", &a, &b );
        MGraph[a].push_back( b );
        inDegree[b]++;
    }

    int k, v;
    scanf( "%d", &k );
    for( int i = 0; i < k; i++ ) {
        copyDegree();
        vector<int> vec;
        for( int j = 0; j < n; j++ ) {
            scanf( "%d", &v );
            vec.push_back( v );
        }
        if( !topSort( vec ) ) { ans.push_back( i ); }
    }

    for( int i = 0; i < ans.size(); i++ ) {
        if( i == 0 ) printf( "%d", ans[i] );
        else printf( " %d", ans[i] );
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值