PAT(A) - 1091. Acute Stroke (30)

7 篇文章 0 订阅


One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26

思路分析:第一次做这种三维的BFS,虽然思路是一样的,但还是没写出来.....英语也不好理解。参考了网上别人的题解。

#include <cstdio>
#include <queue>

using namespace std;

int MGraph[1290][130][61];
int visit[1290][130][61];

int X[6] = { 0, 0, 0, 0, 1, -1 };
int Y[6] = { 0, 0, 1, -1, 0, 0 };
int Z[6] = { 1, -1, 0, 0, 0, 0 };

int m, n, l, T;

typedef struct Point {
    Point( int xx, int yy, int zz ) {
        x = xx;
        y = yy;
        z = zz;
    }
    int x;
    int y;
    int z;
} Point;

bool judge( Point p ) {
    // 越界
    if( p.x >= m || p.x < 0 || p.y >= n || p.y < 0 || p.z >= l || p.z < 0 ) return false;
    // 0的区域不可访问
    if( MGraph[p.x][p.y][p.z] == 0 ) return false;
    // 已经访问过
    if( visit[p.x][p.y][p.z] ) return false;

    // 其他情况返回true
    return true;
}

int bfs( Point start ) {
    queue<Point> q;
    q.push( start );
    visit[start.x][start.y][start.z] = 1;

    int tot = 0;
    while( !q.empty() ) {
        Point cur = q.front();
        q.pop();

        tot++;
        for( int i = 0; i < 6; i++ ) {  // 枚举6个方向
            int newX = cur.x + X[i];
            int newY = cur.y + Y[i];
            int newZ = cur.z + Z[i];

            Point p( newX, newY, newZ );
            if( judge( p ) ) {
                q.push( p );
                visit[p.x][p.y][p.z] = 1;
            }
        }
    }

    return tot;
}

int main() {
    scanf( "%d%d%d%d", &m, &n, &l, &T );

    for( int i = 0; i < l; i++ )
        for( int j = 0; j < m; j++ )
            for( int k = 0; k < n; k++ ) {
                scanf( "%d", &MGraph[j][k][i] );
            }

    int sum = 0;
    for( int i = 0; i < l; i++ )
        for( int j = 0; j < m; j++ )
            for( int k = 0; k < n; k++ ) {
                if( !visit[j][k][i] && MGraph[j][k][i] == 1 ) {
                    Point p( j, k, i );
                    int ans = bfs( p );
                    if( ans >= T ) {    // 大于等于阈值累计和
                        sum += ans;
                    }
                }
            }

    printf( "%d\n", sum );

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Acute3D Viewer是一款用于查看Acute3D软件生成的三维模型的软件。以下是Acute3D Viewer的安装教程。 第一步,打开Acute3D Viewer的安装文件,双击运行该文件。 第二步,选择您要将Acute3D Viewer安装到的目标文件夹。您可以选择默认目标文件夹,也可以自定义目标文件夹。点击“下一步”继续。 第三步,选择开始菜单文件夹。您可以选择将Acute3D Viewer的快捷方式添加到开始菜单的默认文件夹,也可以选择创建一个新的文件夹。点击“下一步”继续。 第四步,选择额外任务。您可以选择添加Acute3D Viewer的桌面快捷方式和快速启动图标。点击“下一步”继续。 第五步,选择安装类型。您可以选择完全安装或者自定义安装。如果您对安装过程不了解,建议选择默认安装。点击“下一步”继续。 第六步,点击“安装”按钮开始安装Acute3D Viewer。安装过程可能需要一些时间,请耐心等待。 第七步,等待安装完成。安装完成后,您可以选择打开Acute3D Viewer。 第八步,启动Acute3D Viewer。在启动Acute3D Viewer之前,系统可能会提示您选择连接Acute3D Viewer的3D模型文件的默认应用程序。您可以选择Acute3D Viewer作为默认应用程序,然后单击“确定”。 这样,您就成功地安装了Acute3D Viewer。现在,您可以使用Acute3D Viewer来查看和浏览Acute3D软件生成的三维模型了。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值