1091. Acute Stroke (30)

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M by N matrix, and the maximum resolution is 1286 by 128); L (<=60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M by N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are "connected" and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.


Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26
/*
 * 此题的关键是不要使用dfs,而是应该使用bfs,dfs递归层次太深会出现栈溢出,使用队列来广度遍历不会出现栈溢出
 */

//方法一:
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int M = 1286;
const int N = 128;
const int L = 60;
bool graph[L][M][N];
struct Place
{
	int i, j, k;
	Place(int _i, int _j, int _k) : i(_i), j(_j), k(_k)
	{
	}
};
queue<Place> que;
int m, n, l, t, value;
int bfs(int i, int j, int k)
{
	int count = 0;
	que.push(Place(i, j, k));
	graph[i][j][k] = false;
	while (!que.empty())
	{	++count;
		int i = (que.front()).i;
		int j = (que.front()).j;
		int k = (que.front()).k;
		que.pop();
		if (i > 0 && graph[i-1][j][k])
		{
			graph[i-1][j][k] = false;
			que.push(Place(i - 1, j, k));
		}
		if (j > 0 && graph[i][j-1][k])
		{	
			graph[i][j-1][k] = false;
			que.push(Place(i, j - 1, k));
		}
		if (k > 0 && graph[i][j][k-1])
		{
			graph[i][j][k-1] = false;
			que.push(Place(i, j, k - 1));
		}
		if (i < l - 1 && graph[i+1][j][k])
		{
			graph[i+1][j][k] = false;
			que.push(Place(i + 1, j, k));
		}
		if (j < m - 1 && graph[i][j+1][k])
		{
			graph[i][j+1][k] = false;
			que.push(Place(i, j + 1, k));
		}
		if (k < n - 1 && graph[i][j][k+1])
		{
			graph[i][j][k+1] = false;
			que.push(Place(i, j, k + 1));
		}
	}
	return count;
}
int main(void)
{
	scanf("%d%d%d%d", &m, &n, &l, &t);
	for (int i = 0; i < l; ++i)
	{
		for (int j = 0; j < m; ++j)
		{
			for (int k = 0; k < n; ++k)
			{
				scanf("%d", &value);
				graph[i][j][k] = (value == 1 ? true : false);
			}
		}
	}
	int maxCount = 0, count;
	for (int i = 0; i < l; ++i)
	{
		for (int j = 0; j < m; ++j)
		{
			for (int k = 0; k < n; ++k)
			{
				if (graph[i][j][k])
				{
					count = bfs(i, j, k);
					if (count >= t)
						maxCount += count;
				}
			}
		}
	}
	printf("%d\n", maxCount);
	return 0;
}

//方法二:
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;

bool graph[60 * 1286 * 128];
int m, n, l, slice;
queue<int> que;
int bfs(int i)
{
	int count = 0;
	graph[i] = false;
	que.push(i);
	int level, temp, row, coloum;
	while (!que.empty())
	{
		++count;
		i = que.front();
		que.pop();
		level = i / slice;
		temp = i % slice;
		row = temp / n;
		coloum = temp % n;
		if (level > 0 && graph[i - slice])
		{
			graph[i-slice] = false;
			que.push(i - slice);
		}
		if (level < l - 1 && graph[i + slice])
		{
			graph[i + slice] = false;
			que.push(i + slice);
		}
		if (row > 0 && graph[i - n])
		{
			graph[i-n] = false;
			que.push(i - n);
		}
		if (row < m - 1 && graph[i + n])
		{
			graph[i + n] = false;
			que.push(i + n);
		}
		if (coloum > 0 && graph[i - 1])
		{
			graph[i - 1] = false;
			que.push(i - 1);
		}
		if (coloum < n - 1 && graph[i + 1])
		{
			graph[i + 1] = false;
			que.push(i + 1);
		}
	}
	return count;	
}
int main(void)
{
	int t, value, index = 0;
	scanf("%d%d%d%d", &m, &n, &l, &t);
	slice = m * n;
	for (int i = 0; i < l; ++i)
	{
		for (int j = 0; j < m; ++j)
		{
			for (int k = 0; k < n; ++k)
			{
				scanf("%d", &value);
				graph[index++] = (value == 1 ? true : false);
			}
		}
	}
	int maxCount = 0, count;
	for (int i = 0; i < index; ++i)
	{
		if (graph[i] == true)
		{
			count =	bfs(i);
			if (count >= t)
				maxCount += count;
		}
	}
	printf("%d\n", maxCount);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值