HDU-1496 Equations

Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0 
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0. 

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}. 

Determine how many solutions satisfy the given equation. 
InputThe input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks. 
End of file.OutputFor each test case, output a single line containing the number of the solutions. 
Sample Input
1 2 3 -4
1 1 1 1
Sample Output
39088
0

使用哈希快速查找,注意最后答案要乘以16

#include <cstdio>
#include <cstring>

#define MAX 2000001

int visit[MAX];
int num[MAX];

int main() {
    int a, b, c, d;
    for( int i = 1; i <= 100; i++ ) num[i] = i * i;
    while( scanf( "%d%d%d%d", &a, &b, &c, &d ) != EOF ) {
        memset( visit, 0, sizeof( visit ) );
        for( int i = 1; i <= 100; i++ ) {
            for( int j = 1; j <= 100; j++ ) {
                visit[a * num[i] + b * num[j] + 1000000]++;
            }
        }
        int sum = 0;
        for( int i = 1; i <= 100; i++ ) {
            for( int j = 1; j <= 100; j++ ) {
                sum = sum + visit[-( c * num[i] + d * num[j] ) + 1000000];
            }
        }
        printf( "%d\n", sum * 16 );
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值