HDU-1269 迷宫城堡

为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。 
Input输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。 
Output对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。 
Sample Input
3 3
1 2
2 3
3 1
3 3
1 2
2 3
3 2
0 0
Sample Output
Yes
No

判断有向图是否为强连通。

#include <cstdio>
#include <algorithm>
#include <vector>
#include <stack>
#include <cstring>

#define MAX 10000 + 10

using namespace std;

vector<int> MGraph[MAX];
int DFN[MAX];
int LOW[MAX];
int inStack[MAX];
int n, m;
int tot = 1;
int cnt = 0;
stack<int> s;

void init() {
    for( int i = 0; i < MAX; i++ ) MGraph[i].clear();
    while( !s.empty() ) s.pop();
    tot = 1;
    cnt = 0;
    memset( DFN, 0, sizeof( DFN ) );
    memset( LOW, 0, sizeof( LOW ) );
    memset( inStack, 0, sizeof( inStack ) );
}

void tarjan( int u ) {
    inStack[u] = 1;
    DFN[u] = LOW[u] = tot++;
    s.push( u );
    for( int i = 0; i < MGraph[u].size(); i++ ) {
        int v = MGraph[u][i];
        if( !DFN[v] ) {
            tarjan( v );
            LOW[u] = min( LOW[u], LOW[v] );
        }
        else if( inStack[v] ) {
            LOW[u] = min( LOW[u], DFN[v] );
        }
    }
    if( LOW[u] == DFN[u] ) {
        int cur;
        cnt++;
        do {
            cur = s.top();
            s.pop();
            inStack[cur] = 0;
        } while( cur != u );
    }
}

void solve() {
    for( int i = 1; i <= n; i++ ) {
        if( !DFN[i] ) {
            tarjan( i );
        }
    }
}

int main() {
    while( scanf( "%d%d", &n, &m ) != EOF ) {
        init();
        if( n == 0 && m == 0 ) break;
        for( int i = 0; i < m; i++ ) {
            int from, to;
            scanf( "%d%d", &from, &to );
            MGraph[from].push_back( to );
        }
        solve();
        printf( "%s\n", cnt == 1 ? "Yes" : "No" );
    }

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值